[ECOS] arm-elf-gdb does not work

Warren Postma warren.postma@adaptivenetworks.on.ca
Wed Nov 6 06:32:00 GMT 2002


Reply to Mildred Frisco:

(a) what exact version of arm-elf-gdb are you using? binary or compiled it
yourself?  If you compiled it yourself, please post your "configure"
statement.
(b) Please give more information on your target hardware.

Try the text mode:

arm-elf-gdb -nw <exename>

# Make serial connection:
tet remotebaud 38400
target remote COM1
# Get the code running and up to the first line in main:
load
break main
c

Then see if it gets to the first line of main, and type S to single step
through the code. That will establish whether the NON-GUI version is
working, and your target environment is working. I am having a lot of
trouble with the GUI version of arm-elf-gdb 5.2, and my target is a
StrongARM 1110 based NanoEngine.  Also, like you, hello-world is a lot more
stable even under the GUI, than larger EXEs.  I think that there is a
serious bug in INSIGHT 5.2, which may be fixed in latest CVS sources, but I
haven't gotten them to build yet.

If you get this far, may I suggest that the problem is that only recently
(version 5.3 and later) has the GUI version developed stability with remote
ARM targets.  I have mixed results with my StrongARM "nanoEngine" target
here.

The fact that the network stuff was linked in gives me a hint, in that
larger and more stressful applications appear to be having problems, but
Hello World programs are working fine for me also.    Our experiences are
not to different here, and the thing we have in common is we're probably
both using arm-elf-gdb 5.2 or lower, and both using arm targets.  HMM.

I am following this up on the INSIGHT mailing lists also.

Regards,

Warren Postma

----- Original Message -----
From: "Mildred Frisco" <mildredf@asti.dost.gov.ph>
> Hi !  I am having a problem with my arm-elf-gdb.  I produced an
application
> hello.elf and downloaded/tested it using arm-elf-gdb and it worked.  I
built
> another ecos with net test configuration.  I wanted to use the test
programs
> produced but when I ran arm-elf-gdb the program did not work.  The memory
> window (I think it's the memory window) in arm-elf-gdb appeared for a
while
> and then back to the prompt.  What seems to be the problem ?
> Thanks.



-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list