[ECOS] about the wireless lan on iPAQ

Gary Thomas gthomas@ecoscentric.com
Wed Nov 6 06:22:00 GMT 2002


On Wed, 2002-11-06 at 07:15, 00917764d wrote:
> I have ported the eCos on iPAQ H3630. Now, I would like to use the wireless 
> lan on iPAQ. I am using the Socket Low Power Wlan card. When I try to modify 
> the ecos sources code, I check that there are some IP setting in the file 
> bootp.c under the /package/redboot/net/bootp.c. The following are what I am 
> talking about.
> 
> static const unsigned char dhcpCookie[] = {99,130,83,99};
> static const unsigned char dhcpEndOption[] = {255};
> static const unsigned char dhcpRequestOption[] = {52,1,3};
> 
> 
>     r.ip_addr[0] = 255;
>     r.ip_addr[1] = 255;
>     r.ip_addr[2] = 255;
>     r.ip_addr[3] = 255;
>     r.enet_addr[0] = 255;
>     r.enet_addr[1] = 255;
>     r.enet_addr[2] = 255;
>     r.enet_addr[3] = 255;
>     r.enet_addr[4] = 255;
>     r.enet_addr[5] = 255;
> 
> Is it necessary for me to modify these code? Please give me some suggestion 
> what I should do. Thanks!!

No, you should not be changing any of these settings.

If you are just trying to force a particular IP address (as
opposed to using BOOTP/DHCP), use the CDL to change that
behaviour.

Does your wireless card do anything yet?  Can you see if it
moves packets in/out?  I'd start with that before worrying
about the IP address to use.

-- 
------------------------------------------------------------
Gary Thomas                  |
eCosCentric, Ltd.            |  
+1 (970) 229-1963            |  eCos & RedBoot experts
gthomas@ecoscentric.com      |
http://www.ecoscentric.com/  |
------------------------------------------------------------


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list