[ECOS] How di I fix this problem in ecos?

MAX Kuo cyk12@it.canterbury.ac.nz
Tue Nov 5 22:31:00 GMT 2002


hi Gray:
I use the configtool 2.11 in red hat 8.0.
It get the same resutl error.
So it that also because gcc 3.X???

max




>===== Original Message From Gary Thomas <gthomas@ecoscentric.com> =====
>On Tue, 2002-11-05 at 17:01, MAX Kuo wrote:
>> hello everyone
>>
>> I use the latest cvs and run a test in ecos.
>> I choose the eb40 template and build the test.
>> but it shows the error below:
>>
>> can anyone tell me how to fix this error??
>>
>>
>> max
>> 
%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%%
>> c/PROGRA~1/REDHAT~1/ecos/packages/language/c/libc/stdio/current/src/input/
>> -mcpu=arm7tdmi -mno-short-load-words -Wall -Wpointer-arith 
-Wstrict-prototypes
>> -Winline -Wundef -Woverloaded-virtual -g -O2 -ffunction-sections
>> -fdata-sections -fno-rtti -fno-exceptions -fvtable-gc -finit-priority
>> -Wp,-MD,src/input/fgetc.tmp -o src/input/language_c_libc_stdio_fgetc.o
>> 
/ecos-c/PROGRA~1/REDHAT~1/ecos/packages/language/c/libc/stdio/current/src/inpu
>> t/fgetc.cxx
>> 
/ecos-c/PROGRA~1/REDHAT~1/ecos/packages/language/c/libc/stdio/current/src/inpu
>> t/fgetc.cxx:129: `
>>    int getc(CYG_ADDRESS (*)[9999])' defined both normally and as an alias
>> make[1]: *** [src/input/fgetc.o.d] Error 1
>>
>
>Don't use GCC-3.x
>
>--
>------------------------------------------------------------
>Gary Thomas                  |
>eCosCentric, Ltd.            |
>+1 (970) 229-1963            |  eCos & RedBoot experts
>gthomas@ecoscentric.com      |
>http://www.ecoscentric.com/  |
>------------------------------------------------------------



-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list