[ECOS] Problems with cache.c for ARM7TDMI

Andrew Lai Tien Long laiandrew@icr.a-star.edu.sg
Tue Nov 5 00:34:00 GMT 2002


Hi all,

I have discovered a problem while compiling tests in Linux(RedHat 7.2) for ARM7TDMI.

After creating the directory, ecos-work, I ran the following commands:

ecosconfig new INTEGRATOR
ecosconfig tree
make
make tests

After running the last command the system complains about line 80 of cache.c.  Apparently, the declaration:

volatile char m[(HAL_DCACHE_SIZE/HAL_DCACHE_LINE_SIZE)*MAX_STRIDE];

cannot be made outside a function.  So I've modified the cach.c file by putting the above statement within the function time0(..).  See attached.  After I did this things WORKED!!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: cache.c
Type: application/octet-stream
Size: 6927 bytes
Desc: not available
URL: <http://sourceware.org/pipermail/ecos-discuss/attachments/20021105/38556cb7/attachment.obj>
-------------- next part --------------
-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss


More information about the Ecos-discuss mailing list