[ECOS] redboot and MIPS malta board

Jonathan Larmour jifl@eCosCentric.com
Mon Nov 4 19:58:00 GMT 2002

   Zhang wrote:
 > Dear all, here is my problem:
 > Firstly I am able to download the prebuild
 > ECOSDIR/images/mips/malta/redboot_ROM.fl to my malta board, it worked,
 > but just for a few minutes. Then I can't download it any more. It
 > always gives me some wierd charactors, and all eight D28 LEDs are
 > green.
 > I tried to rebuild, ( using the import configure file
 > .../misc/redboot_ROM.ecm, and srecconv.pl -ES L -A 29 to convert),
 > still, I can't download the result redboot.fl, and all D28 LEDs are
 > green again. (but no weird charactors this time)
 > I remembered that I typed (SHIFT + 4) when redboot was working on my
 > malta board. It is very strange that whenever I typed that, my malta
 > board is dead and I have to reset it. After several times, the
 > resetting is not working for me any more, and I even can't download any
 > more.
 > Anybody gives some hint about this?

Shift 4 is '$' and makes RedBoot switch into GDB debugging mode which as 
far as _you_ can tell well make it appear dead. You need to do a power 
cycle or full reset. Alternatively you can try typing:

followed by return to ensure the line is flushed. That should resuscitate 
the redboot prompt.

eCosCentric       http://www.eCosCentric.com/       <info@eCosCentric.com>
--[ "You can complain because roses have thorns, or you ]--
--[  can rejoice because thorns have roses." -Lincoln   ]-- Opinions==mine

Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss

More information about the Ecos-discuss mailing list