[ECOS] The Nano Saga - Part the Third - libsupc++

Warren Postma warren.postma@adaptivenetworks.on.ca
Fri Nov 1 09:17:00 GMT 2002


Yay. I got the whole eCos target libraries built for my nano target,
including getting past the GCC 3.2's problems with compiling the getc()
function with it's __getc alias declarations. (Thank you everyone for
helping me get this far.) I'm *SO* close, I can taste it. (Tastes like
Chicken, if you must know.)

Anyway, I have got to the point that of finding how to build libsupc++ for
my arm-elf targets, and I assume this is what  'newlib' is, because I found
the following post by Jonathan Larmour:

-- archive snippet begin --

From: Jonathan Larmour <jlarmour at redhat dot com>
...
Chris Garry wrote:
> <snip>
> cannot find libsupc++.a
...
libsupc++.a should be output by the gcc build provided you do a complete
gcc build. The way to do this is download newlib (
http://sources.redhat.com/newlib ) and put symlinks to the newlib and
libgloss directories within that in your gcc source tree. Then rebuild gcc
from scratch and do make all install rather than make all-gcc install-gcc

-- end snippet  --

So, while I did use the --with-newlib flag in my configuration of GCC 3.2,
it doesn't appear that my GCC tarball had newlib in it (quick check confirms
this). So did that flag get ignored?

For reference, I configured/built GCC 3.2 thus:

mkdir -p /tmp/build/gcc
cd /tmp/build/gcc
/usr/src/gcc-3.2-1/configure \
    --target=arm-elf \
    --prefix=/tools \
    --exec-prefix=/tools/H-i686-pc-cygwin \
    --with-gnu-as \
    --with-gnu-ld \
    --with-newlib -v 2>&1 | \
     tee /tmp/built/gcc/gcc-configure.out
make -w all-gcc install-gcc LANGUAGES="c c++"

So next, I got newlib from cvs, but as I have no idea how to do the
"symlink" stuff Jonathan mentions, like where to put it, and what to call
it.

So, I tried to build it separately (do the usual mkdir
/tmp/configure/newlib, run configure from there with my target options, th n
run make) with same switches as if I were building GCC and so on.).

Anyways, I built it, and it seemed to do a lot of building of library stuff,
then I ran "make install", and while it installed a lot of stuff (probably a
bad thing) still no libsupc++ installed  /tools (as per my
specified --prefix).

So do I have to go back to GCC 2.x now or can anybody help me get GCC 3.2
libsupc++ (newlib?) support so I can do the linkage of the eCos Tests to run
on my target.

Thanks!

Warren Postma


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list