[ECOS] iq80310: pci_init_find_82559s() never returns

Jonathan Larmour jlarmour@redhat.com
Tue May 14 13:23:00 GMT 2002


Daniel Franke wrote:
> 
> (gdb) continue
> Continuing.
> intel_i82559_init
> pci_init_find_82559s()
> --cut--
> 
> That's the end. The 7-segment display shows '02' (instead '01') and I get
> no more response.
> (I'm not used to gdb, I just followed the doc to get here.)
> 
> The target is a iq80310, Rev. F.
> A previously installed Linux works with the NIC - but only if 'diag' is
> started before and it has done its reset. Now the NIC is recognized by
> RedBoot - and later by Linux. If I run Linux at once (without calling
> diag) neither NIC nor PCI bus are recognized.
> 
> --RedBoot (reset after diag)--
> ...
> Exiting Hardware Diagnostics - Reenabling Data Cache!
> Ethernet eth0: MAC address 00:80:4d:46:22:54
> IP: 192.168.0.100, Default server: 192.168.0.1
> RedBoot(tm) bootstrap and debug environment, version R1.24 - built
> 16:53:49, Se1
> Platform: IQ80310 (XScale)
> --end--
> 
> Has anyone got eCos on IQ80310 using the internal NIC running and may
> help?

Is this in a PC or backplane? We've heard of conflicts with the PC Bios
before - if it's in a PC make sure S3-2 is off.

Alternatively there are some fixes we've made to the iq80310 that may help
this, however they aren't public yet until eCos v2 (which is now being
actively worked on again!)

Jifl
-- 
Red Hat, Rustat House, Clifton Road, Cambridge, UK. Tel: +44 (1223) 271062
--[ "You can complain because roses have thorns, or you ]--
--[  can rejoice because thorns have roses." -Lincoln   ]-- Opinions==mine

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list