[ECOS] how use termios_lookup? some question

??? char@suprema.co.kr
Tue Mar 19 00:57:00 GMT 2002


Processor is Intel StrongARM and baudrate is 115200.
When data is encrypted, ARM board is missing some data. But when data is not
encrypted, ARM board receive data very well(!).

Thanks...

----- Original Message -----
From: <harri.siirtola@vtt.fi>
To: <ecos-discuss@sources.redhat.com>
Sent: Tuesday, March 19, 2002 5:19 PM
Subject: Re: [ECOS] how use termios_lookup? some question


> >...
>  >And, My program is transfering between PC to ARM board(customized).
>  >ARM board is missing some data(not all data) which received binary
data(raw
>  >data of image) from PC.
>
> Which processor are you using? If it's Atmel AT91xxx, data is surely
> dropped as there's no fifo in the UART. I don't know if termios can use
> interrupt driven comms but even with that, the current Atmel ports are
broken.
>
>  >following source is termios setting.
>  >
>  >-----------------------------------------
>  >    newtio.c_cflag =3D (BAUDRATE | CS8 | CLOCAL | CREAD);
>
> If your baudrate is above 19200, you can't count on polled mode to keep
up.
>
>       Harri
>
>
> --
> Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
> and search the list archive: http://sources.redhat.com/ml/ecos-discuss



-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list