[ECOS] Cannot communicate with RedBoot on Viper board

Erik Reikes ereikes@hotmail.com
Fri Mar 8 03:47:00 GMT 2002

>Hi All,
>Thanks to Erik for pointing out that I needed a null serial cable to
>connect to the Viper and not a pass-through like I was using.  I am now
>able to run RedBoot and download and debug the sample eCos applications
>using Insight.
>I am now having some problems with the Ethernet interface in RedBoot.

I have yet to get this to work.  I think the redboot/ecos ethernet and tcp 
code is _real_ shaky.  I'm not sure if its just this target's driver or 
what, but debugging hasn't worked for me and I messed with it for a full 

You might try rebuilding redboot from the updated sources.  I've tried this 
and the ping is a bit more reliable but still no dice on the debugger.

Good luck.

-Erik Reikes

Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss

More information about the Ecos-discuss mailing list