[ECOS] Version 1.3.net tests, sample app building

Bennett Keller bkeller@sorensontech.com
Thu Mar 7 11:00:00 GMT 2002


Sorry for the repost of these two issues if you've already seen them. They
were sent to the list in a 'digest' that had some problems and I couldn't
read my copy very well so I suspect some may have just deleted it. If 
anyone has any ideas on how to resolve these issues, I'd appreciate it.

Bennett

*****

Subject: building Version 1.3.net tests from configuration tool

I am trying to build the redboot test suites to run on a PID board with ARM7
processor. I am using Win2000 to run the configuration tool, and version 
1.3.net of the config tool. I am using code for the build that I got via
anon 
FTP last week. When I select Build ->Tests, the build exits with the
following 
error:

/d/tools/H-i686-pc-cygwin//arm-elf/bin/ld: Warning: _umodsi3.o does not
  support interworking, whereas /ecos-d/builds/pid28_redboot_install/tests
  /hal/common/current/tests/cache.exe does not
/d/tools/H-i686-pc-cygwin//arm-elf/bin/ld: Warning: _dvmd_tls.o does not
  support interworking, whereas /ecos-d/builds/pid28_redboot_install/tests
  /hal/common/current/tests/cache.exe does not
/ecos-d/builds/pid28_redboot_install/lib/libtarget.a(redboot_main.o): In
  function `do_go': /ecos-d/net28/ecos/packages/redboot/current/src/
  main.c:549: undefined reference to `RedBoot_version'
collect2: ld returned 1 exit status
make[1]: ***
[/ecos-d/builds/pid28_redboot_install/tests/hal/common/current/tests/cache]
Error 1
make[1]: Leaving directory
`/ecos-d/builds/pid28_redboot_build/hal/common/current'
make: *** [tests] Error 2
make: Leaving directory `/ecos-d/builds/pid28_redboot_build'

Can anyone give me a hand as to resolving this error? Thanks in advance.

*******
Subject: Sample application build

Hello, 

I am trying to compile the 'hello.c' sample application to run on a PID
board with ARM7 processor. I am using Win2000 to run the configuration 
tool, and Cygwin with gcc to compile the application against the build. If 
I use version 1.3.net of the config tool to build the 'all' template for the

'ARM development board (PID)', using the repository I checked out via the 
FTP site on Feb 28, I get the following error:

$ arm-elf-gcc -g -I//d/builds/pid28_all_install/include hello.c
-L//d/builds/pid28_all_install/lib -Ttarget.ld -nostdlib
/d/tools/H-i686-pc-cygwin//arm-elf/bin/ld: address 0x903ac of a.out section
  .bss is not within region ram
collect2: ld returned 1 exit status

If I use instead version 1.3.1 of the config tool and repository to build
the 'all' 
template for the same target I do not get the error. Can anyone give me a 
hand as to resolving this error with the newest code? Thanks in advance.


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list