[ECOS] confused about running program on remote target

Erik Reikes ereikes@hotmail.com
Wed Jan 30 15:11:00 GMT 2002

The problem as I understand it is that the Redboot.bin from Redhat doesn't 
reserve enough ram.  When newer applications are downloaded, it overwrites 
redboot and crashes the debugger.

The file you need to change is an .ldi file in the pkgconf directory.  Then 
you need to recompile the redboot.bin file.

If you search over the past couple of days you'll see that I have been 
having the same problem.  If you get redboot.bin to compile, please let me 
know what you did as I have been beating my head against the wall for a few 
days to no avail.  Looks like some kind of problem in the disk IO 
assembler... blech.  I've been trying to work around it, but at this point 
I'm out of ideas.

Good luck!

-Erik Reikes

>From: michael shiloh <michael@magrittesystems.com>
>To: <ecos-discuss@sources.redhat.com>
>Subject: [ECOS] confused about running program on remote target
>Date: Wed, 30 Jan 2002 14:18:56 -0800 (PST)
>MIME-Version: 1.0
>Received: from [] by hotmail.com (3.2) with ESMTP id 
>MHotMailBE21BAC80064400431CDD1F91D430EA30; Wed, 30 Jan 2002 14:12:26 -0800
>Received: (qmail 26788 invoked by alias); 30 Jan 2002 22:12:11 -0000
>Received: (qmail 26755 invoked from network); 30 Jan 2002 22:12:11 -0000
>Received: from unknown (HELO magritte.magrittesystems.com) ( 
>  by sources.redhat.com with SMTP; 30 Jan 2002 22:12:11 -0000
>Received: from localhost (michael@localhost)by magritte.magrittesystems.com 
>(8.11.6/8.8.7) with ESMTP id g0UMIua06617for 
><ecos-discuss@sources.redhat.com>; Wed, 30 Jan 2002 14:18:56 -0800
>From ecos-discuss-return-13019-ereikes Wed, 30 Jan 2002 14:13:18 -0800
>Mailing-List: contact ecos-discuss-help@sources.redhat.com; run by ezmlm
>Precedence: bulk
>List-Subscribe: <mailto:ecos-discuss-subscribe@sources.redhat.com>
>List-Archive: <http://sources.redhat.com/ml/ecos-discuss/>
>List-Post: <mailto:ecos-discuss@sources.redhat.com>
>List-Help: <mailto:ecos-discuss-help@sources.redhat.com>, 
>Sender: ecos-discuss-owner@sources.redhat.com
>Delivered-To: mailing list ecos-discuss@sources.redhat.com
>summary: i'm having trouble running an ecos application on a
>target, via gdb and a serial port. i tried both "run" and
>ecos:       from cvs (updated today)
>host:       linux redhat 7.2
>target:     x86 pc
>binutils:   2.11.2
>gcc core:   3.0.3
>gcc c, c++: 3.0.3
>gdb:        5.1.1
>my target is connected to my host via a serial port. target
>is booting from redboot.bin on a floppy. redboot.bin is the
>precompiled version from the website.
>target screen shows a boot, and if i run minicom on the
>serial port instead of gdb i get the boot messages there:
>   RedBoot(tm) bootstrap and debug environment - built
>   05:37:52, Jun  8 2001
>   Platform: PC (I386)
>   Copyright (C) 2000, 2001, Red Hat, Inc.
>   RAM: 0x00000000-0x000a0000, 0x0007c080-0x000a0000 available
>   RedBoot>
>   (now quit minicom and reboot)
>i build hello.c for my target:
>   # file hello
>     hello: ELF 32-bit LSB executable, Intel 80386, version 1,
>     statically linked, not stripped
>and attach using gdb:
>   #   i386-elf-gdb -nw hello
>   GNU gdb 5.1.1
>   [...]
>   This GDB was configured as "--host=i686-pc-linux-gnu 
>   (gdb) set remotebaud 38400
>   (gdb) target remote /dev/ttyS0
>   Remote debugging using /dev/ttyS0
>   0x00007f38 in ?? ()
>       at
>   123 } // atexit()
>   Current language:  auto; currently c++
>   (gdb) load
>   Loading section .text, size 0x7ab0 lma 0x108000
>   Loading section .rodata, size 0x265 lma 0x10fab0
>   Loading section .data, size 0x248 lma 0x10fd18
>   Start address 0x108000, load size 32605
>   Transfer rate: 20064 bits/sec, 74 bytes/write.
>   (gdb) run
>   The program being debugged has been started already.
>   Start it from the beginning? (y or n) y
>   Starting program: /home/mshiloh/ecos/cvs/ecos/examples/hello
>   Don't know how to run.  Try "help target".
>now try using "continue" instead of "run":
>   [...]
>   (gdb) continue
>   Continuing.
>   (at this point it hangs, without having printed anything)
>so my main question is how do i run a program on my target?
>possibly related, can anyone tell me if there is a problem
>with the "atexit()" line? is it an error, or is it just
>telling me where it's stopped? is this ok?
>any help much appreciated.

Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.

More information about the Ecos-discuss mailing list