[ECOS] Clock problem with eCos 1.3.1 using uITRON compatibili ty

jecer@Rational.Com jecer@Rational.Com
Fri Jan 25 12:46:00 GMT 2002


Thanks for your help. I tried your suggestion (incrementing a global
variable in  Cyg_RealTimeClock::isr() and Cyg_RealTimeClock::dsr() ) and
determined that the two functions are not being called at all. That
explainst why get_tim always returns 0.

Is there anything that needs to be done explicitly to enable the clock
interrupt?

Jiri

-----Original Message-----
From: Jonathan Larmour [mailto:jlarmour@redhat.com]
Sent: January 25, 2002 2:38 PM
To: jecer@Rational.Com
Cc: ecos-discuss@sources.redhat.com
Subject: Re: [ECOS] Clock problem with eCos 1.3.1 using uITRON
compatibility


jecer@Rational.Com wrote:
> 
> Hello,
> 
> I am using eCos 1.3.1 with uITRON compatibility on the i386 pc target. The
> kernel is almost default. It was created by:
> 
> > ecosconfig new pc uitron
> > ecosconfig resolve
> > ecosconfig check
> > ecosconfig tree
> 
> The only thing that I changed is the memory layout. Anyhow, here is the
> problem.

May I first suggest using anonymous CVS? We're gearing up for an eCos 2.0
release because 1.3.1 is so old.

> It seems that the clock is not working at all. Any call to dly_tsk() and
to
> tslp_tsk() will not return even when supplied with a positive argument. I
> also tried the supplied uITRON compatibility tests. test1 hangs after the
> first call to dly_tsk(), and testintr fails with the following:

You could increment some global variable in
kernel/VERSION/src/common/clock.cxx in both Cyg_RealTimeClock::isr() and
Cyg_RealTimeClock::dsr() to see if the int is being received at all.

Jifl
-- 
Red Hat, Rustat House, Clifton Road, Cambridge, UK. Tel: +44 (1223) 271062
Maybe this world is another planet's Hell -Aldous Huxley || Opinions==mine



More information about the Ecos-discuss mailing list