[ECOS] Redboot (loading file )

Paul Fine pfine@delcomsys.com
Tue Jan 22 06:29:00 GMT 2002

I have also had a similar problem loading files with RedBoot.  I am working 
on a port of eCos to Motorola's MPC8260 ADS board.

I only have a serial port for comm.

I built the hello example, used objcopy to create an srec file and then 
tried to download the srec with the command

RedBoot> load -m xmodem

I then select Transfer->Send File from the HyperTerm menu and browse to 
find my hello.srec file.

The transfer goes smoothly until packet 1151 (144K into the transfer) and 
then the transfer hangs up.  Eventually HyperTerm
gives up and RedBoot prints the message

*** Warning! Checksum failure - Addr: 4c7f0, 9D <> 00
xyzModem - CRC mode, 1152(SOH)/0(STX)/0(CAN) packets, 28 retries

Strangely enough, the line in the srec file with the starting address 
0x4c7f0 has a checksum of F2.

I thought that this was a problem with my port, but I have seen several 
messages lately which indicate that the downloads are stopping at around 
144K, so perhaps I was looking in the wrong place for the bug.

I have not had any success debugging the problem.  Can someone suggest a 
method ?(I only have the 1 serial port for comm available).

Incidentally, using a raw download (load -r -m xmodem -b 0x20000) hangs up 
at 288K.

At 05:45 AM 1/22/02 -0800, you wrote:
>Hi all,.
>currently I am working on  redboot and I want to load
>certain files with redboot ,
>for that  I
>  connect two pc one is having linux & other is booted
>  from redboot , with serial ports.
>When I initialised minicom what I saw is that redboot
>promt comes over in  minicom window at linux pc,
>with that I could  run the redboot commands.
>Then  I run following
>commonds from redboot prompt.
>              Load -r -v -m xmodem  filename -b
>The filename is my executable file of linux
>application programe .similarly I also tried for other
>  files.
>the redboot loaded the file in memory.
>first up all I load a file which is of 60 kb ,It
>loaded fine but when I executed it giving the
>command go <address>.. it did nothing except giving
>the a charecror string .The file was .o file
>,compiled by gcc .
>Secondly , I loaded the other file which is in  binary
>  of 170 kb ,but redboot loaded only 145 kb ,and then
>giving the error ,...incomplete transfer, retries
>count exceeded .
>What can I do for loading the bigger file?
>what type of file I can load in to the redboot ?
>Can I load ecos's libtarget.a in to it for debugging?
>please help me
>  umesh
>Do You Yahoo!?
>Send FREE video emails in Yahoo! Mail!

More information about the Ecos-discuss mailing list