[ECOS] Redboot (loading file )

umesh jaiswal umeshcj@yahoo.com
Tue Jan 22 05:45:00 GMT 2002


Hi all,.
currently I am working on  redboot and I want to load
certain files with redboot ,
for that  I
 connect two pc one is having linux & other is booted
 from redboot , with serial ports. 

When I initialised minicom what I saw is that redboot
promt comes over in  minicom window at linux pc,
with that I could  run the redboot commands.
Then  I run following
commonds from redboot prompt.
             Load -r -v -m xmodem  filename -b
<base_address>
The filename is my executable file of linux
application programe .similarly I also tried for other
 files.
the redboot loaded the file in memory.
first up all I load a file which is of 60 kb ,It
loaded fine but when I executed it giving the 
command go <address>.. it did nothing except giving
the a charecror string .The file was .o file 
,compiled by gcc .

Secondly , I loaded the other file which is in  binary
 of 170 kb ,but redboot loaded only 145 kb ,and then 

giving the error ,...incomplete transfer, retries
count exceeded .

What can I do for loading the bigger file?

what type of file I can load in to the redboot ?

Can I load ecos's libtarget.a in to it for debugging?
how?

please help me

Regards!!

 umesh

__________________________________________________
Do You Yahoo!?
Send FREE video emails in Yahoo! Mail!
http://promo.yahoo.com/videomail/



More information about the Ecos-discuss mailing list