[ECOS] eCos on Atmel EB40

Lin Ming lm1121@yeah.net
Wed Feb 27 22:38:00 GMT 2002


Hi All,

I am also porting eCos to EB40. But I am still an beginner in this embedded system. So would you give me some help about the steps of porting or give me some tutorial to start? I would greatly appreciate it! 

Thank you!

Best Regards,
Lin Ming
2002-02-28 09:08:37

2002-02-26 20:53:00
You wrote:
>I had to remove libsupc++.a from the GROUP directive in arm.ld in order
>to get eCos to compile for the EB40.  I would have had problems with
>any ARM target since the compilation of libsupc++.a fails when I build
>my GCC3xx toolchain.  Since removing this directive has not caused any
>problems for me, I have not gone further on investigating the
>libsupc++.a errors.
>
>
>--- Ravi Arulanantham <baker@mail.meer.net> wrote:
>> Hi,
>> I am trying to build eCos for the EB40 with ConfigTool 1.3.net.
>> 
>> With Build->tests
>> I get the following error while building hal/common/current tests
>> 
>> ld: cannot find libsupc++.a
>> 
>> Please help,
>> thanks
>> baker
>> 
>
>Regards,
>Rob
>rmartin@sonoranfoothillseng.com
>
>
>__________________________________________________
>Do You Yahoo!?
>Yahoo! Greetings - Send FREE e-cards for every occasion!
>http://greetings.yahoo.com
>
>-- 
>Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
>and search the list archive: http://sources.redhat.com/ml/ecos-discuss



-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list