[ECOS] Network code unstable (Still Not Solved).

Gary Thomas gthomas@redhat.com
Tue Feb 19 05:46:00 GMT 2002


On Tue, 2002-02-19 at 01:41, Andrew Lunn wrote:
> On Mon, Feb 18, 2002 at 03:07:16PM -0800, Pieter Truter wrote:
> > Here is the promissed test app.
> > I am not sure what is working and what is not.
> > Sometimes it crash after 100 loops, sometimes after the first loop. If I put
> > it in ROM it always crash in the first loop.
> 
> I cannot see anything obvious wrong.
> 
> Do you have asserts enabled? If not, enable them. They are part of the
> INFRA package.
> 
> How does it crash? Lock solid? Drop in gdb? Throw an exception? Where
> in the cycle? Always at the beginning of the transfer? Always near the
> end? Somewhere in the middle? Does it vary?
> 
> Could it be something else on the network. Use tcpdump to grab all
> broadcast traffic and any unicast traffic to/from the node which is
> not tftp. See if anything happens as it crashes eg DHCP renewal, an
> NTP broadcast, a ping of death from some hacker in your network?

These are very good suggestions.  The problem is probably an elusive
one though.  I've run the test program here continuously for the last
12 hours, including from ROM, with no failures.


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list