[ECOS] TCP/IP Package Installation questions

Jonathan Larmour jlarmour@redhat.com
Thu Feb 14 10:54:00 GMT 2002


Paul Randall wrote:
> 
> Hi All,
> 
> I have tried to add the TCP/IP package to eCos in two different ways and
> have been unsuccessful both times.  I am running Windows 98 using
> cygwin.
> 
> First, I tried downloading the net-1.0b1.epk file.  I downloaded it and
> copied it to c:\temp on my hard drive but when I tried to add the
> package with the Package Administration Tool, I get the following error:
> 
> PKGADMIN
> Command execution error:
> extracting pkgadd.db:
> couldn't execute "gunzip": no such file or directory
> 
> I have gunzip in my c:\cygwin\bin directory but the Package
> Administration Tool can't find it.

I think it assumes it is on the PATH. Is it?

> I also read that the TCP/IP package could be checked out from the
> anonymous cvs repository so I tried a cvs login from the cygwin bash
> shell which failed as follows:
> 
> $ cvs -d :pserver:anoncvs@sources.redhat.com:/cvs/ecos login
> (Logging in to anoncvs@sources.redhat.com)
> CVS password:
> cvs [login aborted]: connect to sources.redhat.com:2401 failed:
> Connection refused
> 
> Any suggestions?

Either the load was too high and so connections were temporarily rejected
(in which case you'll need to retry). Or you are behind a firewall set to
reject all connections out. I would point out Dave Airlie's mirror as
mentioned at the bottom of http://sources.redhat.com/ecos/anoncvs.html but
that's temporarily offline too :-|.

Jifl
-- 
Red Hat, Rustat House, Clifton Road, Cambridge, UK. Tel: +44 (1223) 271062
Maybe this world is another planet's Hell -Aldous Huxley || Opinions==mine

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list