[ECOS] Can't Run Hello on an EP7211

Douglas Bush dbush@extremeeng.com
Thu Feb 14 10:14:00 GMT 2002


Folks,

I'm running an EDB7211.

I've taken a current eCos from cvs (about Feb 12), rebuilt the REDBOOT
RAM and ROM images using the current ecm files.  My customizations were
to set a default IP address in-case BOOTP wasn't available, remove the
LCD interface (untick in configtool 2.08), and finally configured the
clock to 18Mhz (required to use the PCMCIA interface which is a future
requirement).  The clock and LCD mods were also made for the kernel.

The RAM and ROM images have installed correctly.  The ROM image boots;

+FLASH configuration checksum error or invalid key
Ethernet eth0: MAC address ff:ff:ff:ff:ff:ff
IP: 172.16.1.240, Default server: 172.16.1.15

RedBoot(tm) bootstrap and debug environment [ROM]
Non-certified release, version UNKNOWN - built 09:43:09, Feb 14 2002

Platform: Cirrus Logic EDB7211 (ARM 720T)
Copyright (C) 2000, 2001, 2002, Red Hat, Inc.

RAM: 0x00000000-0x00fd7000, 0x0000cb48-0x00fb4000 available
FLASH: 0xe0000000 - 0xe1000000, 128 blocks of 0x00020000 bytes each.
RedBoot>

It also seems to work with GDB when GDB connects to the device and
loads;

$ debugger
GNU gdb 5.1
Copyright 2001 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you
are
welcome to change it and/or distribute copies of it under certain
conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for
details.
This GDB was configured as "--host=i686-pc-cygwin --target=arm-elf"...
0xe000cd08 in ?? ()
Loading section .rom_vectors, size 0x40 lma 0x20000
Loading section .text, size 0x32c8c lma 0x20040
Loading section .rodata, size 0x1a257 lma 0x52ccc
Loading section .data, size 0xd40 lma 0x6cf24
Start address 0x20040, load size 318563
Transfer rate: 54223 bits/sec, 306 bytes/write.
(gdb) c
Continuing.
Interrupted while waiting for the program.
Give up (and stop debugging it)? (y or n) y
(gdb) quit

Apart from the wonderful transfer rate, and what appears to be a corrupt
MAC address, I never hear from hello world again.  I have tried turning
on tracing and ASSERTS in the kernel, but this doesn't help at all.

The tools used are; binutil-2.10.1, gcc-2.95.2, and insight-5.1.

I also tried to use an older kernel and application (previously somewhat
talkative with an old canned redboot image) with this redboot, and its
completely dead too.

Does anyone know what might be wrong with this?  I could try this at
full clock speed... Should I try to use a newer canned redboot?  Does
anyone have any experience with EP-7211's running at 18Mhz (or am I the
only one)?
 
Douglas Bush
Extreme Engineering
#17, 6025 - 12 St. SE
Calgary, Alberta, Canada
T2H 2K1

Phone: 403 640 9494 ext-208
Fax: 403 640 9599

http://www.extremeeng.com



--
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list