[ECOS] Problem TFTPing from redboot

Douglas Bush dbush@extremeeng.com
Wed Feb 13 13:01:00 GMT 2002


Folks,

I can't seem to TFTP load an image into an EDB7211.  I'm using Windows
2000, and the redboot which is already installed on my target is the
standard (canned) redboot from May 2001.

I start up my server application, then type;
load -h 172.16.1.15 -m tftp redboot.srec

The on target redboot responds with;
Can't load 'redboot.srec': operation timed out

I've tried 2 3Com tftp servers, and TFTPD32.  I've also tried to
increase the timeouts on the servers.

Ethereal shows what appears to be a valid TFTP request, but its not
being accepted by any of the TFTP servers.

TFTPD32 said "Error: RecvFrom returns 10040: <A message sent on a
datagram was larger than the internal message buffer or some other
network limit, or the buffer used to receive a datagram into was smaller
than the datagram itself."

I suspected my windows MTU size so I tried pinging with 1472 byte
packets with no fragmentation and that worked just fine.

Does anyone have any experience with this?  Also... What is everyone
else using for a TFTP server for either cygwin or Windows 2000?

Douglas Bush
Extreme Engineering
#17, 6025 - 12 St. SE
Calgary, Alberta, Canada
T2H 2K1

Phone: 403 640 9494 ext-208
Fax: 403 640 9599

http://www.extremeeng.com



-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list