[ECOS] xscale build problem

Jing Luo Jing@vicom.com
Thu Feb 7 18:03:00 GMT 2002


> Hi,
> 
> I tried to build library via configure tools 1.3.net using xscale-elf-gcc,
> but the following error message in red showed up.
> 
> Which version I should use for cygwin and xscale-elf-gcc so that I can
> build the library.
> 
> The current cgywin version: 1.1.8-2
> 
> xscale-elf-gcc: xscale-010827
> 
> [error message]
> make -r -C hal/arm/arch/current arm.inc
> make[1]: Entering directory
> `/ecos-c/TEMP/ecos_build/xscale-80311_build/hal/arm/arch/current'
> xscale-elf-gcc -Wall -Wpointer-arith -Wstrict-prototypes -Winline -Wundef
> -Woverloaded-virtual -g -O2 -ffunction-sections -fdata-sections -fno-rtti
> -fno-exceptions -fvtable-gc -finit-priority -mapcs-frame
> -I/ecos-c/TEMP/ecos_build/xscale-80311_install/include
> -I/ecos-c/cygwin/ecos_cvs/packages/hal/arm/arch/current
> -I/ecos-c/cygwin/ecos_cvs/packages/hal/arm/arch/current/src
> -I/ecos-c/cygwin/ecos_cvs/packages/hal/arm/arch/current/tests -I.
> -Wp,-MD,arm.tmp -o hal_mk_defs.tmp -S
> /ecos-c/cygwin/ecos_cvs/packages/hal/arm/arch/current/src/hal_mk_defs.c
> C:\cygwin\usr\local\xscale\XSCALE~1\H-I686~1\bin\xscale-elf-gcc.exe: ***
> conflicting versions of cygwin1.dll detected.  Use only the most recent
> version.
> 
>       0 [unknown (0xA08)] ? 0 lock_pinfo_for_update: rc 0, pinfo_mutex
> 0xFFFFFFFF, Win32 error 6
> make[1]: *** [arm.inc] Error 1
> make[1]: Leaving directory
> `/ecos-c/TEMP/ecos_build/xscale-80311_build/hal/arm/arch/current'
> make: *** [build] Error 2
> make: Leaving directory `/ecos-c/TEMP/ecos_build/xscale-80311_build'
> 
> 
> Best Regards,
> 
> Jing Luo
> Firmware Engineer
> VICOM Systems Inc,
> 47281 Bayside Parkway
> Fremont, CA 94538
> 
> Tel: 510-743-1166
> E-mail: Jing.luo@vicom.com
> 
> 



More information about the Ecos-discuss mailing list