[ECOS] GNU binary Utility

Jing Luo Jing@vicom.com
Wed Feb 6 19:17:00 GMT 2002


Hi,

Thanks for your reply. But I haven't solved the first question.
I followed the instruction on the site:
http://sources.redhat.com/ecos/tools/win-arm-elf.html

but I can't Configure the GNU Binary Utilities using:
    mkdir -p /tmp/build/binutils
    cd /tmp/build/binutils
    /ecos/src/binutils/configure --target=arm-elf \
      --prefix=/tools \
      --exec-prefix=/tools/H-i686-pc-cygwin \
      -v 2>&1 | tee configure.out 

I used the cvs site for binutils.
The process hanged and the configure.out has nothing.

Did someone have the same problem?

-----Original Message-----
From: Pete Barrie [mailto:peter@cis.strath.ac.uk]
Sent: Wednesday, February 06, 2002 3:47 PM
To: Jing Luo
Cc: ecos-discuss@sources.redhat.com
Subject: Re: [ECOS] patch for gcc


At 15:40 06/02/2002 -0800, Jing  Luo wrote:
>Hi all,
>
>I tried to follow your instruction to install . After installed patch, I
>want to update the timestamp, but it failed.
>
>contrib/egcs_update --touch
>[error messages as following]
>'contrib' is not recognized as an internal or external command,
>operable program or batch file.
>
>And I can't find the 1.3.net from cvs.

I think Erik means:
go to:
http://sources.redhat.com/ecos/anoncvs.html

then near bottom of page:
Updated configuration tools for Windows
Self-extracting zip files for updated binaries of both the eCos 
Configuration Tool for Windows

Pete


>-----Original Message-----
>From: jecer@Rational.Com [mailto:jecer@Rational.Com]
>Sent: Thursday, January 31, 2002 1:35 PM
>To: ereikes@hotmail.com
>Cc: michael@magrittesystems.com; ecos-discuss@sources.redhat.com
>Subject: RE: [ECOS] confused about running program on remote target
>
>
>Erik,
>
>thank you very much for your help. I got everything working as well. Here
is
>a summary for those who are having problems running on the i386 target:
>
>Get the latest sources. The precompiled redboot.bin available from Red Hat
>will not work with recent eCos, and so you will have to build redboot as
>well. After creating the configuration file for redboot (ecosconfig new pc
>redboot), you will have to import ecosconfig import redboot_FLOPPY.ecm
>(ecosconfig import
>$ECOS_REPOSITORY/hal/i386/pc/current/misc/redboot_FLOPPY.ecm). My mistake
>was to follow
>http://sources.redhat.com/ecos/docs-latest/redboot/rebuilding-redboot.html
>and configuring redboot for booting from ROM. This is accurate for other
>platforms, but it doesn't for for booting from floppy on a PC. I am sure
>that the directions for building for floppy booting are somewhere in the
>documentation; I didn't find them. After that, everything should work as
>described in the getting started document.
>
>Once again, thanks
>
>Jiri
>
>-----Original Message-----
>From: Erik Reikes [mailto:ereikes@hotmail.com]
>Sent: January 31, 2002 2:07 PM
>To: jecer@Rational.Com; michael@magrittesystems.com;
>ecos-discuss@sources.redhat.com
>Subject: RE: [ECOS] confused about running program on remote target
>
>
>Huzzah!
>
>Success!
>
>Here's what I did to make it work :
>I'm using win2k professional FYI.
>The first thing I did was delete everything... ecos, cygwin, all the files
>and directories in cygwin, every tar.gz and tar.bz2 I downloaded for the
>whole project.
>
>I then redownloaded everything in the exact versions as specified on the
>redhat ecos directions :
>
>binutils 2.10.1
>gcc 2.95.2 core and g++ (straight from sources.redhat/ecos)
>insight 5.0
>The insight patch.
>The gcc patch.
>The new config tool 1.3.net from ecos.
>
>
>I installed _every_ package in cygwin, no matter how seemingly unrelated.
>
>Then I followed the exact directions on the ecos "how to build the tools
>page".  Right down to the exact directories specified for builds and
>everything.  I directly cut and pasted from their web page, in the exact
>same order.
>
>Then I installed the 1.3.1 exe distribution.
>Then I unzipped the 1.3.net configtool right into the
>Programfiles|RedHAt|ecos|tools|bin directory.
>Then I ran their registry update fragment.
>Then I cvs'd a fresh brand new copy of the ecos distribution in a directory
>/Master_Ecos.
>I cp -r *'d everything in there to a directory in cygnus called
/devel_ecos.
>
>Then I started configtool 1.3.net and before doing anything I pointed the
>repository to c:/cygwin/devel_ecos.
>
>Then I made a directory c:/TEMP/ecos_build.
>I set build|template to i386 pc target and switched the packages to minimal
>and saaved the ecc as c:/TEMP/ecos_build/i386min.ecc.  Then set the build
>(c:/cygwin/tools/H-i386-pc-cygwin/bin) and tools (c:/cygwin/bin) paths and
>said build|library.  This build of minimal tools succeeded and was more of
a
>
>test than anything.
>
>then I said file|new, set build|template to i386 pc target and set the
>packages to redboot.  After this I said file|import
>c:/cygwin/devel_ecos/packages/hal/i386/pc/current/misc/redboot_FLOPPY.ecm.
>
>Then I said file|save c:/TEMP/ecos_build/i386redboot.ecc and said
>build|library.  Lo and behold there was a redboot.bin in the
>i386redboot_install/bin directory.  I dd'd the file to the floppy as
>explained in the redboot documentation and it booted up giving me redboot.
>
>I tried to run the tests from a template = i386|default build, but they are
>still referencing the c drive as //c/, and I haven't gotten around to
>figuring out some sort of path mangling to get around this, but I went into
>cygwin and went to my repository directory /devel_ecos/examples.  Changed
>the settings in the makefile for Repository_install (where your libtarget.a
>lives... for me it was something like /cygdrive/c/TEMP/i386default_install
>and build option (uncommented the i386 pc one) and said make at the command
>line.  The examples made and I said gdb helloworld.exe. up pops insight, I
>set the options for target to COM1 38400 and said run.  It downloaded and a
>screen flickered by real quick but when I managed to get it stopped it said
>: "Hello ecos-world...about !@#$ time!".
>
>Ok, I forgot the part where I edited the hello-world source with my own
>little message and !@#$ was something else probably not appropriate for
this
>
>forum.  ;)
>
>Now if you've gotten this far this is the most important step : I shut down
>my computer, found a short round glass (some call it a tumbler) placed two
>ice cubes in it followed by about three fingers of Jack Daniels, downed it
>and went to sleep.
>
>I'm not at all sure what the actual problem (or problems) I was having, but
>I originally tried to use gcc-3.0.3 with the newest binutils and insight
>5.1, I later tried to switch to 2.95.2, but it didn't seem to help.  Some
>combination of corruptions of tools and/or repository and/or configtool was
>probably the culprit.
>
>Sorry for the rambling, no complete sentences, poorly punctuated message.
>
>Hope that helps!
>
>-Erik Reikes
>
>
> >Erik and Michael,
> >
> >I am having the same problem (see my post from January 29). I don't think
> >that redboot is the problem since I ran older version of eCos (which
> >suffers
> >from other problems) with it. I did try to rebuild the redboot.bin file,
> >but
> >it didn't boot at all. I am still looking at this, and I'll keep you
posted
> >if I find something relevant. Please let me know if you were successful
> >with
> >recompiling redboot.
> >
> >thank you
> >
> >Jiri
>
>
>
>_________________________________________________________________
>Get your FREE download of MSN Explorer at http://explorer.msn.com/intl.asp.



More information about the Ecos-discuss mailing list