[ECOS] access cvs server problem, please advise

David Oberbeck dgo@microsynetics.com
Tue Feb 5 19:55:00 GMT 2002


Greetings,

On Tuesday 05 February 2002 18:58, Jonathan Larmour Wrote Thusly:
> Pete Barrie wrote:
> > At 14:20 05/02/2002 +0000, Jonathan Larmour wrote:
> > >David Oberbeck wrote:
> > > > Subject: Re: [ECOS] access cvs server problem, please advise
> > > > Date: Mon, 4 Feb 2002 16:39:40 -0700
> > > > From: David Oberbeck <dgo@microsynetics.com>
> > > > To: HLin@hauppauge.com
> > > >
> > > > Harry,
> > > >
> > > >    Are you behind a firewall? If you, you need port 2401 opened for
> > > > outbound traffic, and a return path for the newly-opened connection.
> > >
> > >Or maybe it was a temporary glitch on sources.redhat.com. It works right
> > >now for what it is worth.
> >
> > I'm getting the same response as below. Running on Win2000.
>
> I just tried it again from my home (not freeserve), and it works fine. Has
> it ever worked before? Can you telnet to sources.redhat.com port 2401? Can
> you ping sources.redhat.com? Can you telnet to sources.redhat.com port 80?
> If so, and you type "HEAD / HTTP/1.0" followed by two returns, does it have
> a Via line?
>
> I wouldn't have expected freeserve to block port 2401 _outbound_. It
> doesn't make much sense, but it does look a lot like firewalling...
>
> Jifl

   It sounds like this is coming down to these issues:

	1. Red Hat CVS server availability.

	2. CVS server authentication issue.

	3. Network issue:
		(a) routing.
		(b) protocol.

   Possibility #1: Based on Harry's email earlier, I spot-checked a
number of times today through our broadband provider, Earthlink, and
eCos CVS was up every time with no errors. Also tried using our backup
modem link through ATT Global, also worked fine (just an awful lot
slower...); So probably not #1 (or possibly an in-your-face example of
sampling theory at it's worst).

   Possibility #2: I just used a machine which has never logged in to
the CVS server (e.g. no .cvspass entries) and did an anonymous login,
then a checkout - this means authentication is working, it's probably
not #2.

   So we are left with network problems: This leaves routing and
protocol.

   Try surfing using your browser of choice to:

	http://sources.redhat.com

   If this works, this means that DNS and routing between your network
and Red Hat is correct; then not #3a.

   Lastly, as Jifl points out, try manually telnetting to the CVS
system. From a shell type:

	telnet sources.redhat.com 2401

and tell us what you see...

   Also as Jifl points out, I could see them blocking this port inbound
(e.g. they don't want you providing CVS services), but not outbound
(e.g. as a client to an external CVS server hosted elsewhere).

   Has this ever worked before? If so, what has changed? Who is your
ISP? Worst case (and they really have blocked this), do you have an
alternative ISP?

   (Sorry for the rambling response, but it's late...)

HTH,
	DGO

-- 

"Entropy Requires No Maintenance"



More information about the Ecos-discuss mailing list