[ECOS] Problem with mbufs...

Gary Thomas gary@mlbassoc.com
Fri Dec 20 05:29:00 GMT 2002


On Fri, 2002-12-20 at 03:20, Daniel Lidsten wrote:
> Hi,
> 
> Do you have some fixed date where the problem of MBUFS goes away?
> 
> I use ecos from 2002-01 and encounter these problem.
> 

The main changes I was thinking about happened in August, 2000,
some five months after 1.3.1 was released.  Those changes made
a huge difference in the stability of the stack in general.

There may still be other problems in there which could lead to
leaking memory.  Have you tried to investigate more?  There are
some functions which you can call to peek into the memory usage
of the stack.  Try calling 'cyg_kmem_print_stats' periodically
to see what it tells you.

> Regards, Daniel
> 
> > On Wed, 2002-12-18 at 09:29, M.PREM KUMAR wrote:
> > > 
> > > Hi Andrew,
> > > 
> > > 	I am using ecos version 1.3.1
> >                    ^^^^^^^^^^^^^^^^^^
> > 
> > Here's your problem!  This code is terribly old and the 
> > network stack has lots of problems, especially in the area of 
> > memory management.
> > 
> > Update to the latest CVS and your problems will probably go away.
> > 

-- 
------------------------------------------------------------
Gary Thomas                 |
MLB Associates              |  Consulting for the
+1 (970) 229-1963           |    Embedded world
http://www.mlbassoc.com/    |
email: <gary@mlbassoc.com>  |
gpg: http://www.chez-thomas.org/gary/gpg_key.asc
------------------------------------------------------------


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list