[ECOS] Capacity problem?

Daniel Lidsten Daniel.Lidsten@combitechsystems.com
Thu Dec 19 06:41:00 GMT 2002


Hi,

I have a quite strange problem with my mcp823e board. Recent to now i
have only developed SW and used a BDM to download it to the board. It
has worked fine! However, i want to be able to boot the board from flash
and that's where my problem is. It seems like sometimes when i boot from
flash and i issue like three large ping (65k) then the board says
"warning: Out of mbufs". This havent occured for several month when
using the BDM as startup for the board. It doesn't come everytime
eighter and if it doesn't appear then i can send almost unlimited data
to the board (i've tried a few Gb)

Worth mentioning is that i use the exact same SW for flash executing and
BDM download.

Any idea of what can be wrong?

I have looked for registers that the BDM sets when it is connected and
that maight differ when it's not but the values set when executing from
flash seems reasonable.

Regards, Daniel

--
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list