[ECOS] eCos 1.3.1 to eCos2 problems

Gary Thomas gary@mlbassoc.com
Wed Dec 18 14:14:00 GMT 2002


On Wed, 2002-12-18 at 13:58, fredrik@wespot.com wrote:
> We have been using our eCos 1.3.1 port for our ARM based ASIC for about
> two years, and it has worked great.
> Now we are trying to move on with eCos2. We checked out the sources two
> weeks ago, but we have problems with the stability. We had to fix solve
> some porting issues, but I believe we sorted them out.
> Some questions remain:
> 
> * We couldnt get the 'USE_BUFFERED_IO' cdl option to be enabled. If so we
> got asserts when eCos is invoking the global contructor of
> stdin/stdout/stderr (some StdStream object calling its superclass
> io_buf(..) I think). Is this a known issue? We tried to change the
> constructing order, but it didnt help.

What CDL option is this?  Which package does it come from?  I don't see
any such CDL.

As for the assert/failure, can you provide any more information?  
Perhaps a test case?

> * After running our system for some time (approx a few minutes, sometimes
> longer) it suddenly crashes in mysterious ways. Is there any known
> problems with the stability right now with the ARM target? When the crash
> occurs, it crashes always in the same line of code and the memory seems to
> be trashed (stack overflow? wrong memory layout?). But when using eCos
> 1.3.1 the crash does not occur. We have tried alot of testing it it really
> seems like its eCos2 which is the problem. Is there any other issues to
> take care of when moving from eCos 1.3.1 to eCos2. I havent found any
> 'eCos1.3.1--->eCos2 guide' document. (new cdl options needed etc?)

There shouldn't be any real need for such a migration document.  eCos 
2.0 is just 1.x evolved - no real big changes except for the license.

Have you tried running your code with asserts enabled?  This will get
some [limited] stack checking as well.  Of course, you could always try
to increase your various stack sizes, just to see if it changes the 
behavior.

> * We have tried GCC 3.0.2, GCC 3.0.4 and GCC 3.2.1 (using binutils 2.13.1,
> newlib 1.10), with the same results. We compile GCC with the arm-elf-gcc
> target. What is arm-ecos-elf-gcc? Is it needed, in that case, why?

'arm-ecos-elf-XXX' tools no longer exist.  Also, we really suggest that
you use GCC 2.95.3 for ARM.

-- 
------------------------------------------------------------
Gary Thomas                 |
MLB Associates              |  Consulting for the
+1 (970) 229-1963           |    Embedded world
http://www.mlbassoc.com/    |
email: <gary@mlbassoc.com>  |
gpg: http://www.chez-thomas.org/gary/gpg_key.asc
------------------------------------------------------------


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list