[ECOS] Redboot "reset" command on iq80321 eval board

Michael Lodman jlodman@rainbow-networks.com
Fri Dec 13 11:14:00 GMT 2002


I've seen it as well but don't have a fix yet.

----------------------------
J. Michael Lodman
Rainbow Network Systems

Rainbow Network Systems, Inc.
11875 Caminito de las Missiones
San Diego, CA 92128
Cell 619-316-1707
Fax 858-592-0302
jlodman@rainbow-networks.com
----------------------------

----- Original Message -----
From: "Rick Richardson" <rickr@mn.rr.com>
To: "eCos Mailing List" <ecos-discuss@sources.redhat.com>
Sent: Friday, December 13, 2002 9:56 AM
Subject: [ECOS] Redboot "reset" command on iq80321 eval board


>
> I'm wondering if anyone has seen this behavior before, and knows of
> a fix.
>
> I have RedBoot in flash on an iq80321 eval board.  The board is
> plugged into a PC, and switches S7E1-X are all set to factory.
>
> After a hard reset, Redboot comes up fine, with the startup messages
> displayed on the serial port, and the LEDs going thru the normal
> sequence to state "A1".  The board is also reachable via the
> ethernet port.
>
> I then issue the RedBoot "reset" command.  This causes a soft reset by
> setting a couple of bits in the ATU PCSR, i.e. exactly what a device
> driver on the host side of the bus would want to do if it wanted to
> reset a board that had gone out to lunch.
>
> The board then goes thru the normal sequence of LED states (scrub
> loop SL, etc.) until it reaches state "A1".  But this time, the
> startup message doesn't come out the serial port, and the board
> cannot be reached via ethernet either.
>
> It looks like "something bad" happens at or after the point where
> vectors.S does the "bl cyg_START".
>
> Anybody seen this and have a fix?  I need the soft reset to work!
>
> -Rick
>
>
> --
> Rick Richardson  rickr@mn.rr.com        http://home.mn.rr.com/richardsons/
> Stock information at your fingertips:   http://linuxtrade.0catch.com/
>
> --
> Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
> and search the list archive: http://sources.redhat.com/ml/ecos-discuss
>
>
>


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list