AW: [ECOS] Error building Redboot for EP7312

Gary Thomas gthomas@ecoscentric.com
Tue Dec 10 08:12:00 GMT 2002


On Tue, 2002-12-10 at 08:53, Backhaus Willy wrote:
> 
> hello,
> 
> 
> > Yes, of course I built this!  This error looks like you were trying
> > to [re]build from a previous attempt, after doing the import.  There
> > were a number of major changes in the sources with that import which
> > might have confused the configuration tools.  Try starting from a
> > totally new configuration and see if the problem persists.
> 
> ok, it works. but I have change the repository another directory and build
> it there. I don't know if this is the controlled behaviour or the eCos
> configuration tool isn't very stable.
> 

I'm not sure what you are saying here, but you should *never* try and
build within the actual repository.  The build system is simply not
designed that way.

You might also consider using the command line tool, since it is
quite intuitive and simple.  For example, to affect this same build:
  % export ECOS_REPOSITORY=/tmp/ecos/packages
  % mkdir /tmp/edb7312_test
  % cd /tmp/edb7312_test
  % ecosconfig new edb7xxx redboot
  % ecosconfig import ${ECOS_REPOSITORY}/hal/arm/edb7xxx/current/misc/edb7312_redboot_ROMRAM.ecm
  % ecosconfig tree
  % make
... of course, substitute your actual source repository for 
"/tmp/ecos/packages" and your own work directory for "/tmp/edb7312_test"

-- 
------------------------------------------------------------
Gary Thomas                       |
eCosCentric, Ltd.                 |  
+1 (970) 229-1963                 |  eCos & RedBoot experts
http://www.ecoscentric.com/       |
email: <gthomas@ecoscentric.com>  |
gpg: http://www.chez-thomas.org/gary/gpg_key.asc
------------------------------------------------------------


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list