AW: AW: [ECOS] Error building Redboot for EP7312

Backhaus Willy w.backhaus@newage-avkseg.com
Mon Dec 9 10:12:00 GMT 2002


hello,


now I have the *.ecm file updates on 06.12, but I still got the error
message.
btw, http://sources.redhat.com doesn't work.



Regards,
Willy


> -----Ursprüngliche Nachricht-----
> Von: Gary Thomas [mailto:gthomas@ecoscentric.com]
> Gesendet: Freitag, 6. Dezember 2002 16:10
> An: Backhaus Willy
> Cc: eCos Discussion
> Betreff: Re: AW: [ECOS] Error building Redboot for EP7312
>
>
> On Fri, 2002-12-06 at 07:51, Backhaus Willy wrote:
> > hello,
> >
> > I made a new project (template : edb7xxx board, packege:
> redboot, processor:
> > ep7312, startup type: ROMRAM) and these are all messages:
> >
> > make -j1 --directory
> "/ecos-c/eCos/CVS-get/ecos/configurations/romram_build"
> >
> > make: Entering directory
> > `/ecos-c/eCos/CVS-get/ecos/configurations/romram_build'
> > make -r -C hal/arm/arch/current headers
> > make -r -C hal/arm/edb7xxx/current headers
> > make -r -C hal/common/current headers
> > make -r -C infra/current headers
> > make -r -C redboot/current headers
> > make -r -C isoinfra/current headers
> > make -r -C language/c/libc/string/current headers
> > make -r -C net/ns/dns/current headers
> > make -r -C services/crc/current headers
> > make -r -C hal/arm/arch/current arm.inc
> > make -r -C hal/arm/arch/current build
> > make: Leaving directory
> > `/ecos-c/eCos/CVS-get/ecos/configurations/romram_build'
> > make: *** [build] Error 2
> >
> > .. actually the same.
> >
> > It seams that the build stops between building /hal/arm/arch/ and
> > /hal/arm/edb7xxx. in the build directory there are 4 object
> files under
> > /arm/arch and none under arm/edb7xxx/.
>
> You still didn't provide the error messages which would lead to
> any useful help :-(  When I ran it, I got these errors:
>     arm-elf-gcc -c  -I/work/et/install/include
> -I/work2/ecos/packages/hal/arm/arch/current
> -I/work2/ecos/packages/hal/arm/arch/current/src
> -I/work2/ecos/packages/hal/arm/arch/current/tests -I.
> -I/work2/ecos/packages/hal/arm/arch/current/src/
> -mcpu=arm7tdmi -Wall -Wpointer-arith -Wstrict-prototypes
> -Winline -Wundef -Woverloaded-virtual -g -O2
> -ffunction-sections -fdata-sections -fno-rtti -fno-exceptions
> -fvtable-gc -finit-priority
> -Wp,-MD,src/redboot_linux_exec.tmp -o
> src/hal_arm_arch_redboot_linux_exec.o
> /work2/ecos/packages/hal/arm/arch/current/src/redboot_linux_exec.c
>
> /work2/ecos/packages/hal/arm/arch/current/src/redboot_linux_ex
> ec.c:75:3: #error
>     make[1]: *** [src/redboot_linux_exec.o.d] Error 1
>     make[1]: Leaving directory `/work/et/hal/arm/arch/current'
>     make: *** [build] Error 2
>
> Which led me straight to the problem.  The attached patch (already
> committed to CVS) will fix this.
>
> --
> ------------------------------------------------------------
> Gary Thomas                       |
> eCosCentric, Ltd.                 |
> +1 (970) 229-1963                 |  eCos & RedBoot experts
> http://www.ecoscentric.com/       |
> email: <gthomas@ecoscentric.com>  |
> gpg: http://www.chez-thomas.org/gary/gpg_key.asc
> ------------------------------------------------------------
>


-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list