[ECOS] ecos configure fails for ARM - I'm out of ideas please help

Bahadir Balban bbbalb@essex.ac.uk
Sun Dec 8 19:14:00 GMT 2002


Hi everybody,

I'm having problems with configuring ecos for ARM E7T.
I tried so many ways, searched the maillist but no help.
Any ideas greatly appreciated...

I am using redhat 7.3 with gcc 3.2, latest binutils and newlib.
(could this be the problem? I tested the toolchain for e7t)

Here's what I'd done and the problem:

I got the latest CVS source typing: 

% cvs -d :pserver:anoncvs@sources.redhat.com:/cvs/ecos co -P ecos

then tried configuring using both configtool-2.11 with GUI and
ecosconfig by typing:

% ecosconfig1314-linux --srcdir=/opt/ecos/ecos/packages/ new e7t
% ecosconfig1314-linux --srcdir=/opt/ecos/ecos/packages/ check
% ecosconfig1314-linux --srcdir=/opt/ecos/ecos/packages/ tree

everything fine so far.
after this when I type:

% make tests

I get the error:

------------------ecosconfig1314-linux error *latestCVS*---------------

make -r -C language/c/libc/stdio/current build
make[1]: Entering directory 
`/opt/ecos/ecosconfig-work/language/c/libc/stdio/current'
arm-elf-gcc -c  -I/opt/ecos/ecosconfig-work/install/include 
-I/opt/ecos/ecos/packages/language/c/libc/stdio/current 
-I/opt/ecos/ecos/packages/language/c/libc/stdio/current/src 
-I/opt/ecos/ecos/packages/language/c/libc/stdio/current/tests -I. 
-I/opt/ecos/ecos/packages/language/c/libc/stdio/current/src/input/ 
-mcpu=arm7tdmi -mno-short-load-words -Wall -Wpointer-arith 
-Wstrict-prototypes -Winline -Wundef -Woverloaded-virtual -g -O2 
-ffunction-sections -fdata-sections -fno-rtti -fno-exceptions -fvtable-gc 
-finit-priority -Wp,-MD,src/input/fgetc.tmp -o 
src/input/language_c_libc_stdio_fgetc.o 
/opt/ecos/ecos/packages/language/c/libc/stdio/current/src/input/fgetc.cxx
/opt/ecos/ecos/packages/language/c/libc/stdio/current/src/input/fgetc.cxx:129: 
`
   int getc(CYG_ADDRESS (*)[9999])' defined both normally and as an alias
make[1]: *** [src/input/fgetc.o.d] Error 1
make[1]: Leaving directory 
`/opt/ecos/ecosconfig-work/language/c/libc/stdio/current'
make: *** [build] Error 2

------------------ecosconfig1314-linux error *latestCVS*---------------

I also tried reverting to the CVS source with latest RHEPL by typing

% cvs update -r last-rhepl -d -P

and doing the same with both configtools, after I type

% make tests

I get the error:

-------------ecosconfig1314-linux *with latest RHEPL*---------------------

make: Leaving directory `/opt/ecos/ecosconfig-work/AEB1_build'
   argument given for parameter 1 of `Cyg_Flag::Cyg_Flag(unsigned int = 0)'
/opt/ecos/ecosconfig-work/AEB1_install/include/cyg/kernel/flag.hxx:102: after 
   previous specification in `Cyg_Flag::Cyg_Flag(unsigned int = 0)'
/opt/ecos/ecos-1.3.1/packages/kernel/v1_3_1/src/sync/flag.cxx:125: default 
   argument given for parameter 1 of `void Cyg_Flag::maskbits(unsigned int = 
0)
   '
/opt/ecos/ecosconfig-work/AEB1_install/include/cyg/kernel/flag.hxx:110: after 
   previous specification in `void Cyg_Flag::maskbits(unsigned int = 0)'
/opt/ecos/ecos-1.3.1/packages/kernel/v1_3_1/src/sync/flag.cxx:149: default 
   argument given for parameter 1 of `void Cyg_Flag::setbits(unsigned int = 
-1)
   '
/opt/ecos/ecosconfig-work/AEB1_install/include/cyg/kernel/flag.hxx:106: after 
   previous specification in `void Cyg_Flag::setbits(unsigned int = -1)'
make[1]: *** [src/sync/flag.o.d] Error 1
make: *** [build] Error 2

-------------ecosconfig1314-linux *with latest RHEPL*---------------------

Is this because I get the sources incomplete?

I use ecos/packages as the CVSROOT when I update - is this correct?

How do I find out what date's CVS repository I am using?

For example last-rhepl is a tag for a certain cvs source, how do I find out 
mine or others?

Which CVS source did others use for building E7T?

Many thanks for reading this far and helping.

Cheers,
Bahadir




--
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list