[ECOS] More eb40a redboot questions

Shannon Holland holland@loser.net
Sun Dec 8 18:36:00 GMT 2002


Ah, thank you! Stupid me had seen those emailsearlier and made a mental 
note to remember them when I got there (which I then forgot...).

Using cygwin, I get an access denied error if I do target remote com1, 
but if I run insight in non command-line mode (I'm using 5.2.1) it can 
connect.

I was able to get registers, but no backtrace or disassembly. Played 
around some more and it took down my whole win2k box (ultimately I want 
to get my dev system working on osx, I may just switch to linux first 
though).

Is there a simple way I can catch redboot before it crashes? To do this 
it would seem that I'd need to set some form of breakpoint that is hit 
once the redboot gdb stub as taken over?

I guess the other thing if figure out ow to get gcc/ld to give me a link 
map.

Any hints would be appreciated - hopefully - I can pay you all back 
someday soon with contributions rather than questions.

Shannon

On Sun, 8 Dec 2002 6:06PM -0800, Tim Drury wrote:
> Shannon Holland wrote:
>> Ok,
>> So I managed to get the eb40a target "think" it's happy. I found
>> Christophe's lists of what he did at
>> http://sources.redhat.com/ml/ecos-discuss/2002-10/msg00397.html and 
>> have
>> done the same thing.
>
> Sorry I haven't responded - I've been working on other projects.
> The eb40a patches I wrote are based on TK's first set of eb40
> patches. I haven't updated them for his latest patch because
> I wanted to wait until his eb40 code made its way into CVS.
> I don't want to constantly be updating a moving target.
>
>> This gives me an eb40a target to compile against.
>> However, I hit some snags. The first big one was that I haven't added 
>> the
>> external sram to my eb40a (leaving me with only the 256Kb on-chip 
>> sram).
>> This left angel very unhappy about loading to the external sram 
>> addresses.
>
> I guess I was lucky when my eb40a board arrived with the external RAM
> already on board.
>
>> So, I tried to add another build configuration (SRAM) to the eb40a 
>> target.
>> This attempts to be angel friendly by only loading code to 0x2000 to
>> 0x20000. Everything seems to build and angel/gdb seem to be happy 
>> about
>> downloading it, but when I quit gdb and open hyperterminal, I don't 
>> get a
>> friendly redboot prompt. instead, for any key I press I get:
>> 	"$T050f:403a0300;0d:00000000;#08"
>> What does this mean? Is this angel trying to tell me something (gdb 
>> seems
>> happy) or redboot?
>
> This is gdb trying to tell you something went wrong.  There were some
> good emails within the last week from someone with a similar problem
> and Gary and others described how to get a gdb backtrace.  Look back
> in the email archives for about a week.
>
>
>> 1. Is the process I used to create the eb40a target still valid with 
>> the
>> latest source tree or should I go back to 1.3.1?
>
> No - stay with the ecos 2.0 code.
>
>> 2. Is what I did to make the sram configuration correct? (I did 
>> actually add
>> an redboot_SRAM.ecm and mlt_arm_at91_eb40a_sram.h/ldi - I can provide 
>> more
>> info on what I did here.
>
> This is one of my gripes with the ecos setup.  It would be nice if the
> memory layout were constrained to just one file, but there are a few
> places it shows up.  You found the .h and .ldi file.  Also look in
> hal_platform_setup.h.  There are some chip select setups (which you
> may not need for the onboard sram) and if you are trying ROMRAM,
> there are some memory values in there.  It's been a while since I
> looked at this stuff...
>
>> 3. what does the output "$T050f:403a0300;0d:00000000;#08" mean?
>
> Gary reads gdb-speak.  Hopefully he'll be along to interpret for you.
>
> -tim drury
>
>
> --
> Before posting, please read the FAQ: 
> http://sources.redhat.com/fom/ecos
> and search the list archive: http://sources.redhat.com/ml/ecos-discuss

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list