[ECOS] Help in running nc6test

elvie hau elvie_hau@yahoo.com
Fri Dec 6 07:04:00 GMT 2002

Good Evening!

I tried running the nc6_test (slave and master). 
However, my target and the nc6_master won't
communicate with each other.  The output of the
nc6_master is always "no route to host".  However, it
seems that the nc6_slave is waiting for commands from
the master. 

Currently, the nc6_master is a FreeBSD 4.5 and i
compiled the nc6_master test using gcc.  The IPv6
address of the FreeBSD is
fe80::206:5bff:fe7c:8a19%xl0.  It also has an
autoconfig address of
fe80:503:20fe:100:206:5bff:fe7c:8a19.  The nc6_slave
is an ARM target wherein IPv6 support is enabled.  In
configuring IPv6, I checked the IPv6 support.  I also
enabled the "Use BOOTP/DHCP" mode which it returned
with an IP address of  Furthermore.  I
checked the "Static IPv6 address prefix" and used the
default which is 3ffe:302:11:2.

Following the instructions documented, I ran the
nc6master with the command:
./nc6master 3ffe:302:11:2::

However, the nc6_master is unable to connect to the
nc6_slave.  Is my IPv6 address wrong?  If it is, what
should i use as an IPv6 address?  If it is not, how do
i set or get my IPv6 address?  Also, is there anything
wrong with my configuration?

Please advise me on what to do next because I am
simply stumped.

Looking forward to a favorable reply.


elvie hau

Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.

Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss

More information about the Ecos-discuss mailing list