[ECOS] GCC Cross-compilers for eCos: --enable-threads --enable-__cxa_atexit?

Bart Veer bartv@ecoscentric.com
Tue Dec 3 15:59:00 GMT 2002


>>>>> "Richard" == Richard CHAN Shih-Ping <cshihpin@dso.org.sg> writes:

    Richard> Bart Veer wrote:
    >> I'll have to look into this, because at some point Linux distributions
    >> may ship with a compiler that behaves like this by default. At first
    >> glance I suspect it will be necessary to add a dummy function

    Richard> Truer words were never spake :-)); I was using a
    Richard> home-brewed native Linux GCC 3.2.1 with
    Richard> --enable-__cxa_atexit but my sysadmin tells me that
    Richard> RedHat 8.0 now ships with patched GCC 3.2 (doesn't fix
    Richard> the weak symbols problem) with the C++ ABI switch
    Richard> enabled.

I have now updated the synthetic target HAL with dummy __cxa_atexit()
and __dso_handle. That appears to allow applications to link without
causing any new problems. People using older compilers should be
unaffected, __cxa_atexit() and __dso_handle should just be eliminated
by link-time garbage collection.

    Richard> Anyway for the interest of the list: I've tried GCC 3.2.1
    Richard> i386-elf and arm-elf with vanilla switch settings and the
    Richard> target libraries and tests build cleanly though I've yet
    Richard> to run them on the boards. However, GCC 3.2.1 + WxWin
    Richard> 2.3.4_GTK/Linux configtool segfaults on startup; not sure
    Richard> what's going wrong here yet. ecosconfig however works.

Could be a problem with wxWin, or with the configtool. Have you tried
building any other wxWin applications?

Bart

-- 
Before posting, please read the FAQ: http://sources.redhat.com/fom/ecos
and search the list archive: http://sources.redhat.com/ml/ecos-discuss



More information about the Ecos-discuss mailing list