[ECOS] Re: printf does not work in helloworld.c

Jonathan Larmour jlarmour@redhat.com
Tue Nov 13 20:58:00 GMT 2001


Andrew Xiang wrote:
> 
> I am trying to make the helloworld program to work.
> 
> I tried 2 ways.
> I compiled the program use the :
> arm-elf-gcc hello.c -Ipath -Lpath -Ttarget.ld nostdio
> I notice the program is 1.3MB, just for a little
> printf.

That'll be mostly debugging info, don't worry about that - your actual
program is much smaller.

> arm-elf-gdb -nw a.out
> run

Shouldn't that be "continue"? Or more specifically it should (potentially)
be something like:

set remotebaud 38400
target remote com1
load
continue

The baud rate to use may be different; or you might be using network
instead of serial.

> 2: arm-elf-gdb launches insight.
> attached target, saw it downloaded the program,
> tried to run, I don't the helloworld get printed
> anywhere. and redboot is stuck!(why)

Have you looked at the console? As in View->console
 
Jifl
-- 
Red Hat, Rustat House, Clifton Road, Cambridge, UK. Tel: +44 (1223) 271062
Maybe this world is another planet's Hell -Aldous Huxley || Opinions==mine



More information about the Ecos-discuss mailing list