[ECOS] Compile Problem: Net package in ARM E7T template (memory layout problem?)

HuangQiang jameshq@liverpool.ac.uk
Tue Nov 13 07:48:00 GMT 2001


Is that means there is something wrong with the memory in my eCOS
configuration(I tried E7T template all, net, default(all with Network
support) package setting)? Is that the default memory layout comes with eCOS
template and default package suitable for app development? ( for just a
simple program shown as below) Should I modified the memory layout comes
with the template setting if I want to include the TCP/IP support for my
app?
Thank you very much.

Best regards

james

-----Original Message-----
From: ecos-discuss-owner@sources.redhat.com
[mailto:ecos-discuss-owner@sources.redhat.com]On Behalf Of Simon
Sent: 19 November 2001 17:33
To: ecos-discuss@sources.redhat.com
Subject: Re: [ECOS] Compile Problem: Net package in ARM E7T template


I don't think so.
512kB is large enough for developing an application with net package.
There are many things which should be cared of, like memory layout.
a good memory layout can avoid many problems and make all things
working well.

Simon
    " Not hard, but easy, I think..."



----- Original Message -----
From: "HuangQiang" <jameshq@liverpool.ac.uk>
To: "eCos" <ecos-discuss@sources.redhat.com>
Sent: Monday, November 19, 2001 11:47 PM
Subject: RE: [ECOS] Compile Problem: Net package in ARM E7T template


Is that means including the Net package will push the app over 512Kb for any
configuration type in eCOS (eg. min, default, net, all)?
If Network support is needed then the app should be larger than 512Kb?

thanks.

-----Original Message-----
From: ecos-discuss-owner@sources.redhat.com
[mailto:ecos-discuss-owner@sources.redhat.com]On Behalf Of Chris Garry
Sent: 19 November 2001 12:14
To: HuangQiang; eCos
Subject: Re: [ECOS] Compile Problem: Net package in ARM E7T template


I think the errors you see when you compile your application are due
to the E7T not having enough memory for your application.  Including
the NET package pushes it over the 512KB limit.

See:
http://sources.redhat.com/ml/ecos-discuss/2001-10/msg00679.html


Chris


----- Original Message -----
From: "HuangQiang" <jameshq@liverpool.ac.uk>
To: "eCos" <ecos-discuss@sources.redhat.com>
Sent: Monday, November 19, 2001 12:12 PM
Subject: [ECOS] Compile Problem: Net package in ARM E7T template


> Dear all:
>     I tried to build eCOS configuration with Net package using ARM E7T
> template in eCOS. When I compiled my application with the eCOS library
> following problem occured.
>
> OS: Win2000
> eCOS configuration Tool 1.3.1.3
> Repository: 2001-4-25 ( also tried on latest version)
> Package: Net
>
>
> Test program1:
>
> main(void)
> {
> int i;
> i = 0;
> }
>
> Test program2:
>
> void cyg_start(void)
> {
> int i;
> i = 0;
> }
>
> Problem when compiling those above applications.
> Problem output attached as a photo file.
>
> I also tried to import the device driver for the ethernet driver on the
ARM
> E7T board. using the  following info.
> http://sources.redhat.com/ml/ecos-discuss/2001-07/msg00961.html. but error
> still occured.
>
> Has anyone tried successful eCOS configuration with ethernet support
> (TCP/IP) for ARM E7T board?
>
> Thanks for any help.
>
> Best regards!
>
>
>
> Mr Huang Qiang
> Postgraduate Student
> Room318 B-Block
> Department Of Electrical Engineering And Electronics
> University Of Liverpool
> Brownlow Hill
> Liverpool L69,3GJ
> UK
>
> Personal website at: http://www.liv.ac.uk/~jameshq
>




More information about the Ecos-discuss mailing list