[ECOS] Questions about EB40 GDB stub build

Deli Geng (David) deli.geng@ncl.ac.uk
Mon Nov 12 19:19:00 GMT 2001


Hi, there,

I don't know if it is the problem of EB40 port or my own environment. When I
tried to build EB40 GDB stub with default options, it stopped with asking
for libsupc++.a.

I thought it was some C++ support lib. So I checked the GCC document and
rebuilt GCC with --enable-languages=c++ option. But the libsupc++.a did not
simply turn out. I tried to make libstdc++-v3 stand along, hoping it could
generate libsupc++, but failed.

So I wondered what was libsupc++.a, whether it was necessary for EB40
package and how to get it? My environment is listed as below. I just built
it without actually building any eCos programme. (EB40 one was the first.)

- binutils-2.11.2
- gcc-core-3.0.2
- gcc-c++-3.0.2
- insight-5.0.92
- CYGWIN_NT-5.0 (from uname)
- Host: windows 2000
- eCos source was just checked out from CVS.
- configure tool: 2.0.8

BTW, can those versions of binutil and gcc packages work well with eCos?

Thanks a lot in advance.

David




More information about the Ecos-discuss mailing list