[ECOS] Problem when building the Tools for ARM development

Huang Qiang jameshq@liverpool.ac.uk
Fri May 11 03:31:00 GMT 2001

hi all:
   I am sorry if I post on the wrong place. and administrator pls delete
this email from the list. but I do hope anybody and offer me some help on
it. Thanks a lot!
   I have built the ARM development tools for Windows before and I can use
it for development, but last week I deleted the cygwin and unistall ecos.
After that I try to reinstall ecos and cygwin again. when I building the ARM
development tools for Windows
I encounter the problem when building the insight 5.0. ( when I using :
make -w all install 2>&1 | tee make.out ) there is some error I can't get
through. I have spent almost a whole week on it but no any luck on it.
I follow the procedure from the web sit: http://sources.redhat.com/ecos/ .
I can build the binutils and gcc , and I also can configure the insight 5.0
but I can't get through the "make -w all ...." command for building the
tools for gdb(insight). I have also tried the newest snapshot of insight and
gcc and binutils, but still the same problem. I am using cygwin 1.3.1.
the error found in the make.out:
 /usr/include/w32api/winnt.h:48: parse error before `CCHAR'
and many the same type errors following this one.

and the in winnt.h line 48 shows:

typedef CHAR CCHAR;

Best regards!

More information about the Ecos-discuss mailing list