[ECOS] Unable to load srec files via serial port
Mynampati, Venkata S.
MynamVS@nsc-msg01.network.com
Tue Jul 24 16:21:00 GMT 2001
On 24-Jul-2001 Mynampati, Venkata S. wrote:
> >> >
> >> > i use this command "load -m ymodem -r -b 0xa1000000".
> >> > Is there any size limitation for x/y modem upload?
> >>
> >> If this is a Motorola S-record file, you probably do not want "-r"
> >>
> >> If it fails for large files, perhaps you are running out of memory.
i stopped using '-r' while uploading for SREC files, but still
after about 1147K, the transfer stops. Windows's Hyper terminal's
'send file' window displays 'no response from remote system'.
The interesting thing is, i used visionclick's probe to peep into
RAM areas. What i found is like this:
ram locations starting from 0xa0308000 to 0xa037138A are good,
i.e they correspond to vmlinux.srec file's contents, but location
0xa037138b onwards it is zero.
Also, RedBoot hangs after this upload fails, but if i cancel upload,
RedBoot works.
I think, the upload process uses some RAM locations which i am
overwriting.is this true ? have you seen this behaviour? what is
happening here and how to over come it? or is there anything i
missed.
Your help is appreciated.
Regards
Venkat
More information about the Ecos-discuss
mailing list