[ECOS] Ethernet on redboot

Gary Thomas gthomas@redhat.com
Tue Dec 11 10:22:00 GMT 2001


On Tue, 2001-12-11 at 11:13, Daniel.Andersson@combitechsystems.com
wrote:
> Hi again,
> 
> >> Right now i am working with the ethernet part and i don't 
> >>seem to get ping
> >> to work - not even the default ip works: "ping -h 
> >>127.0.0.1". What can be
> >> the problem here?
> >
> >RedBoot does not support a loopback interface (this doesn't make much 
> >sense for a bootstrap loader).
> >
> >What happens if you turn on network debugging?  You can do this via 
> >'fconfig' or just hard-wire it in redboot/src/net/net_io.c
> 
> I now have a lot of debug information but what are the supposed result? What
> shall i be able to see with this printout? (see below)
> 
> In current case i use redboot build template but i also tried to make a
> default build with the config tool (together with the networking package)
> but i get a lot of conflicts when trying that. This is also the case when
> configuring for an mbx860. THe conflicts are:
> 
> "requires" constraint not satisfied: CYGINT_ISO_STRING_BSD_FUNCS
> "requires" constraint not satisfied: CYGBLD_ISO_BSDTYPES_HEADER ==
> "<sys/bsdtypes.h>"
> "requires" constraint not satisfied: CYGBLD_ISO_NETDB_PROTO_HEADER ==
> "<net/netdb.h>"
> "requires" constraint not satisfied: CYGBLD_ISO_NETDB_SERV_HEADER ==
> "<net/netdb.h>"

I'll have to defer these to another authority.  What is your host 
(build) platform?  Have you tried building using 'ecosconfig'?

> 
> How shall i proseed here? Do i have any connection between these two
> problems?

The dumps below indicate that your device is not receiving any data, 
even broadcast packets.

You should also check on your host (whatever device you are trying to
send data to) that something is arriving on the ethernet "wire".  A 
program like tcpdump can be used to sniff the activity on the network
and would be your next logical step forward.





More information about the Ecos-discuss mailing list