[ECOS] EPI's ICE + gcc

Xavier Wang xavierwang@ms19.url.com.tw
Tue Oct 17 05:30:00 GMT 2000


I'm using EPI's MAJIC ICE with a Lexra Lx4180 (mips) evaluation board.
I've built gcc 2.95.2 and other GNU tools with target for Toshiba Tx39. I
want to
debug the code generated by mips-tx39-elf-gcc using the EPI's debugger.

The debugger's manual said that it supports both ELF and COFF formats. But
when I tried to load the program, the debugger complained that the ELF file
not contain .mdebug, .debug or .stab section. There are indeed many .debug*
sections in the file but no one is exactly .debug, and the .mdebug is
discarded by the link script (target.ld). I removed the discard command to
back the .mdebug section and then the debugger could load the program, but I
could only see the source/symbols of vectors.S
(in eCos\packages\hal\mips\arch\v1_3_1\src), all other parts of the program
in disassembly form only. It's very strange.

I'd searched the archives database of this mailing list and tried some other
found there, such as -gdwarf-2, -gcoff, -gstabs, etc. but still failed. Did
I miss

I'm sorry for my poor English.
Thanks a lot.


More information about the Ecos-discuss mailing list