[ECOS] GDB Download on i386 target hangs

Nick Garnett nickg@cygnus.co.uk
Wed Oct 11 07:20:00 GMT 2000


Christian Plessl <cplessl@ee.ethz.ch> writes:

> >If you are still having problems with other PCs, perhaps the next step
> >is for me to send you an executable I built here, and seen whether
> >that runs for you.
> 
> You wont belive it, my troubles disappeared. A friend emailed me a i386 
> ecos bootsector and it worked. hmm, then I tried to copy my own bootsector 
> on the floppy and it worked as well! The solution: I used another floppy. 
> My first floppy seems to be somewhat broken! I cannot imagine how this can 
> happen, but obviously, the floppydisk is damaged in that way, that ecos 
> with stubs can start and download an executable, but after this it crashes! 
> Lesson learned: never trust a floppy disk ;)

This sounds really wierd. Maybe a strangely formatted floppy? 

> 
> Thanks to Nick and Jesper for their help.
> 

No problem, glad you're on your way at last. 


-- 
Nick Garnett, eCos Kernel Architect
Red Hat, Cambridge, UK



More information about the Ecos-discuss mailing list