[ECOS] building development tools

Andrey Panchenko ur4ukj@gmx.de
Wed Dec 6 12:42:00 GMT 2000


Hello Jonathan,

Mittwoch, Mittwoch, 6. Dezember 2000, you wrote:

>> Yes,
>> in  insn-flags.h:      extern rtx gen_beq            PROTO((void));
>> 
>> in rtl.h              extern rtx gen_beq            PROTO((rtx));
>> 
>> So, configure script is not working very properly.
>> I've tried to change void to rtx but it a moment it failed again:
>> 
>> stmt.c: In function `expand_end_case':
>> stmt.c:5292: too many arguments to function `gen_casesi'
>> make[1]: *** [stmt.o] Error 1
>> 
>> And changes in gen_casesi from void to rtx don't help.
>> Any suggestions ?

[ ... ]

JL> The generation of insn-flags.h is handled by the genflags program which is
JL> part of the build. However it's meant to "just work". I just tried it now
JL> for me for the i386-elf target and it worked for example. If this is the
JL> same target you are using, try installing the attached insn-flags.h file in
JL> the gcc subdirectory of your build tree.

I've tried your h-file and that step passed, but later:

./genrecog ./config/i386/i386.md > tmp-recog.c
genrecog: Two actions at one point in tree for insns "tstsf_cc" (6) and "tstdf_c
c" (8)
after 31 definitions
make[1]: *** [s-recog] Error 33

:(


Best regards,
 Andrey                            mailto:ur4ukj@gmx.de




More information about the Ecos-discuss mailing list