[ECOS] gdb/insight questions

Lewin A.R.W. Edwards larwe@larwe.com
Tue Dec 5 06:26:00 GMT 2000


Well, practically everything works - I can compile apps, I can connect to 
the target board and I can load programs. I have a couple of gdb questions 
though.

Q1: I don't understand where console I/O goes by default; I would have 
assumed to the gdb console but it seems not? My hello world app has a 
printf in it; by default, where does this output go? Can someone please 
verify to me that this is the right process:

* compile
* arm-elf-gdb -nw a.out
* (gdb) set remotebaud 38400
* (gdb) target remote com1
* (gdb) load
* (gdb) continue

I also tried enabling serial port 2 and fprintfing a message to /dev/ttys2 
or whatever it is, and I get my output message on the second port so the 
program is definitely running (yay!).

Q2: (Relatively minor) I can only run command-line gdb, not insight. I even 
tried recompiling insight but when I run it I get an MB_ICONSTOP messagebox 
that says:

Can't find a usable main.tcl in the following directories:
C:/CYGWIN/TOOLS/share/gdbctl C:/CYGWIN/TOOLS/gdbtcl 
C:/CYGWIN/TOOLS/gdb/gdbtk/library C:/CYGWIN/TOOLS/gdb1.0/gdbtk/library

C:/CYGWIN/TOOLS/share/gdbtcl/main.tcl: can't read "errMsg": no such variable
can't read "errMsg": no such variable
while executing "tk_messageBox -title Error -message "Could not find the 
lwidgets libraries. Got nameofexec: [info nameofexecutable]
Error(s) were :\n$errMsg" -icon e..."
invoked from within
"if {![find_iwidgets_library]} {
tk_messageBox....................

(lots more stuff).

I can run native insight with no problems.
=== Lewin A.R.W. Edwards (Embedded Engineer)
Work: http://www.digi-frame.com/
Personal: http://www.zws.com/ and http://www.larwe.com/



More information about the Ecos-discuss mailing list