[ECOS] Building the stub

Jonathan Larmour jlarmour@redhat.co.uk
Mon Aug 14 11:13:00 GMT 2000


> Àå¿øÈ£ wrote:
> 
> After build libtarget,
> I did change to the directory hal/common/current/src/stubrom
> and type make, according to doc, but Nothing happend.

That sounds like a documentation bug.

What you need to do is choose the "stubs" template in the eCos
configuration tool, and build eCos for that.
 
file://C/PROGRA~1/REDHAT~1/eCos/packages/hal/common/v1_3_1/src/stubrom/stubrom.c
> powerpc-eabi-gcc -msoft-float -mcpu=860 -g -nostdlib -Wl,--gc-sections
> -Wl,-static -L//C/My_eCos/jwh_test/test2_install/lib -Ttarget.ld -o
> file://C/My_eCos/jwh_test/test2_install/bin/gdb_module.img
> src/stubrom/gdb_module.o
> /tools/H-i686-pc-cygwin/powerpc-eabi/bin/ld: address 0xfc00bf18 of
> file://C/My_eCos/jwh_test/test2_install/bin/gdb_module.img section .data
> is not within region ram
> /tools/H-i686-pc-cygwin/powerpc-eabi/bin/ld: address 0xfc00bf4c of
> file://C/My_eCos/jwh_test/test2_install/bin/gdb_module.img section .sbss
> is not within region ram
> /tools/H-i686-pc-cygwin/powerpc-eabi/bin/ld: address 0xfc00f400 of
> file://C/My_eCos/jwh_test/test2_install/bin/gdb_module.img section .bss
> is not within region ram
> collect2: ld returned 1 exit status
> make[1]: *** [//C/My_eCos/jwh_test/test2_install/bin/gdb_module.img]
> Error 1
> make[1]: Leaving directory
> `/cygdrive/c/My_eCos/jwh_test/test2_build/hal/common/v1_3_1'
> make: *** [build] Error 2
> 
> what's wrong?

This would imply that the GDB stub image it is trying to build is too big.
If you haven't chosen the "stubs" template, then definitely do that.
Otherwise, which powerpc target is this? And can you not use the prebuilt
GDB stub images supplied with eCos in the "loaders" subdirectory?

Jifl
-- 
Red Hat, 35 Cambridge Place, Cambridge, UK. CB2 1NS  Tel: +44 (1223) 728762
"Plan to be spontaneous tomorrow."  ||  These opinions are all my own fault


More information about the Ecos-discuss mailing list