[ECOS] webserver don't run on ecos.

GARCIA Guillermo guga@teamlog.fr
Wed Aug 9 02:34:00 GMT 2000


Hello !

>I just tried this on the same target hardware as you and it worked
>straight out of the box.  I'm using a Linux development host with
>sources equivalent to the latest anonymous CVS tree.


I suppose the problem comes from my developpement host (WinNT ;).
In the makefile I had to compile webcomp, did i have to change something in
this line :

webcomp:
 cc -o webcomp -O2 -DWEBS -DUEMF -DOS="Linux" -DLINUX -I.. ../webcomp.c

and put something like that :

webcomp:
 gcc -o webcomp -O2 -DWEBS -DUEMF -DOS="WindowsNT" -DWIN -I.. ../webcomp.c
/*(I didn't have cc so i change it to gcc.)*/

I tried this changes and I had an error of include : winnls.h not found.
I had search this file but i didn't find it. I removed this include
and it compile correctly but I still have the bus error.

>
>Here are the basic steps I took:
>  mkdir /work/edb7212_net
>  cd /work/edb7212_net
>  ecosconfig new edb7212 net
>  ecosconfig tree
>  -- edit ecos.ecc
>    cdl_option CYGNUM_LIBC_MALLOC_MEMPOOL_SIZE {
>       user_value 1638400
>    };
>  make


to build eCos i use the red hat configuration tool so i didn't understand
what you do. But i think eCos was well build.

>
>  mkdir /work/webs21
>  cd /work/webs21
>  gzip -d </tmp/Webs21.tar.gz | tar -xvpf -
>  cd ECOS
>  -- edit Makefile
>    [gary@hermes ECOS]$ diff Makefile{~,}
>    11c11
>    < PKG_INSTALL_DIR := /work/net_test/install
>    ---
>    > PKG_INSTALL_DIR := /work/edb7212_net/install
>  make

I did the same thing but i had the bus error.
Did u ran Webs21 in ROM or in RAM ?

>
>That's all!  No changes to any other files were necessary and it just
>built and ran.
>
what about webrom ?

best regards,

Guillermo.



More information about the Ecos-discuss mailing list