[ECOS] webserver don't run on ecos.

Gary Thomas gthomas@redhat.com
Tue Aug 8 15:23:00 GMT 2000


On 08-Aug-2000 GARCIA Guillermo wrote:
> hi all,
> 
> the bus error comes from
> the following line in file sym.c :
> 
> 430  return sum % tp->hash_size;
> 
> where tp->hash_size = 0 !!!
> 
> did i do something wrong during compilation ?
> 

I just tried this on the same target hardware as you and it worked
straight out of the box.  I'm using a Linux development host with
sources equivalent to the latest anonymous CVS tree.

Here are the basic steps I took:
  mkdir /work/edb7212_net
  cd /work/edb7212_net
  ecosconfig new edb7212 net
  ecosconfig tree
  -- edit ecos.ecc 
    cdl_option CYGNUM_LIBC_MALLOC_MEMPOOL_SIZE {
       user_value 1638400
    };
  make

  mkdir /work/webs21
  cd /work/webs21
  gzip -d </tmp/Webs21.tar.gz | tar -xvpf -
  cd ECOS
  -- edit Makefile
    [gary@hermes ECOS]$ diff Makefile{~,}
    11c11
    < PKG_INSTALL_DIR := /work/net_test/install
    ---
    > PKG_INSTALL_DIR := /work/edb7212_net/install
  make

That's all!  No changes to any other files were necessary and it just
built and ran.





More information about the Ecos-discuss mailing list