[ECOS] Run Tests in NEC VR4373

Ling Su lingsu@palmmicro.com
Fri Aug 4 14:42:00 GMT 2000


> >
> > Then how should I interpret the error message "Cannot access memory at
> > address 0x0"?
>
> That probably means the debug information generated by GCC is bad, or that
> GDB is not reading it correctly. Experience says the former is more
likely.
> This is something you'd have to take up with the GCC folks at
> http://gcc.gnu.org/ really. Either that or Charles may have some advice
(or
> may even be able to give you the tools he's using!).
>
Hi, Charles,

Have you ever experienced the same probelm? I applied your Vr4300.ecc,
actually I modified corresponding option based on template vr4300-->kernel.

When I run test, the result is the same as my last post. I run it manually
on "hello.exe", I got the "Cannot access memory at address 0x0" message. I
begun to wonder if my toolchain build is correct.

Can you tell me what snapshot version you use for the binutils, egcs and
insight? You use WinNT or Linux?

Sorry for the bothering, and thanks a lot for any hint!

Rgds,
-Ling




More information about the Ecos-discuss mailing list