[ECOS] Problems when building Insight

Alberto Stapelfeld astapelfeld@ieee.org
Thu Apr 20 15:16:00 GMT 2000


I'm using the following files :

binutils-000416.tar
gcc-core-2.95.2.tar
gcc-g++-2.95.2.tar
insight+dejagnu-weekly-20000412.tar
full.exe  (Cygwin)
cygwin-20000301.tar.gz
ecos-net-gcc-2.95.2-patchset

Then I followed the instruction of the doc : "Building the Intel x86
development tools for Windows", During the step 6 (Build and install
Insight), I get these messages :

....
gcc -g -O2       -Wl,--subsystem,console -o gdb.exe main.o libgdb.a
../bfd/libbfd.a ../readline/libreadline.a ../opcodes/libopcodes.a
./../intl/libintl.a ../libiberty/libiberty.a `if test -r
../libtermcap/libtermcap.a; then echo ../libtermcap/libtermcap.a; else
echo -ltermcap; fi`



../libgui/src/libgui.a -L/tmp/build/gdb/itcl/itcl/win -litcl30 -L/tmp/build/
gdb/itcl/itk/win -litk30 -L/tmp/build/gdb/tix/win/tcl8.0 -ltix4180 -L/tmp/bu
ild/gdb/tk/win -ltk80 -L/tmp/build/gdb/tcl/win -ltcl80      -lm -lm
../libiberty/libiberty.a -luser32 -lshell32 -lgdi32 -lcomdlg32 -ladvapi32
g:\CYGWIN~1\H-I586~1\bin\..\lib\gcc-lib\i586-cygwin32\egcs-2.91.57\..\..\../
libtermcap.a(tputs.o): In function `tputs':
/home/noer/src/b20/comp-tools/devo/libtermcap/tputs.c:72: undefined
reference to `_ctype_'
/home/noer/src/b20/comp-tools/devo/libtermcap/tputs.c:75: undefined
reference to `_ctype_'
/home/noer/src/b20/comp-tools/devo/libtermcap/tputs.c:80: undefined
reference to `_ctype_'
g:\CYGWIN~1\H-I586~1\bin\..\lib\gcc-lib\i586-cygwin32\egcs-2.91.57\..\..\../
libtermcap.a(termcap.o): In function `tgetent':
/home/noer/src/b20/comp-tools/devo/libtermcap/termcap.c:251: undefined
reference to `_ctype_'
g:\CYGWIN~1\H-I586~1\bin\..\lib\gcc-lib\i586-cygwin32\egcs-2.91.57\..\..\../
libtermcap.a(getcap.o): In function `cgetnext':
/home/noer/src/b20/comp-tools/devo/libtermcap/getcap.c:686: undefined
reference to `_ctype_'
collect2: ld returned 1 exit status
make[1]: *** [gdb.exe] Error 1
make[1]: Leaving directory `/tmp/build/gdb/gdb'
make: *** [all-gdb] Error 2
make: Leaving directory `/tmp/build/gdb'

What's wrong?


Alberto Stapelfeld.










More information about the Ecos-discuss mailing list