[ECOS] help me,the same error in gcc patch.

Jonathan Larmour jlarmour@redhat.co.uk
Thu Apr 20 04:12:00 GMT 2000


> xuas wrote:
> 
> we use a computer with an oprating sysytem of redhat6.1 and we download
> all the reqired files from the http://sourceware.cygnus.com/ecos/,but
> when we followed the instruction of installation ,a question come
> out,that is ,when  building the tools,after we have extract the sources
> for each tool directory in turn and apply a small number of source
> patches that are required to fix outstanding problems and add eCos
> support to the tools,then Download the  ecos-net-gcc-2.95.2-patchset
> patch to a file and be about to patch the files using the command patch
> -p0 < ecos-net-gcc-2.95.2-patchset ,errors occur and it say that Hunks
> failed (for example:Hunk #56 failed at 8596 etc ),but I do not know how
> to do next ,could you please spend your precious time to answer me
> ,thanks a lot .please answer the address :xuas@csrd.org.
> thanks

This should definitely not happen - the patch definitely applies against
gcc 2.95.2. Are you sure you are using gcc 2.95.2 sources?

Are you sure you saved the file to disk, rather than cut-and-pasting?

Try patch -l -p0 and see if that is any better. You'll probably need to
unpack fresh sources again first.

Jifl
-- 
Red Hat, 35 Cambridge Place, Cambridge, UK. CB2 1NS  Tel: +44 (1223) 728762
"Plan to be spontaneous tomorrow."  ||  These opinions are all my own fault


More information about the Ecos-discuss mailing list