[ECOS] building tests

Paul Kinzelman PaulK@isdcorp.com
Thu Apr 13 10:28:00 GMT 2000


Yes, I did View->Console after starting Insight. I did:
arm-elf-gdb dhrystone&
View->Console
File->target (setup)
Run->Run (downloads, stops at breakpoint)
Breakpoint message shows in console window with prompt.
Then I tried 3 different things after this

1) If I type 'c' to the console, it says
'Continuing' and never comes back. But if I wait
for how long the test takes, and then reset
and wakeup the board, all of a sudden I do get the
printout.

2) If I on the 'continue' button on the gui, the clock
shows up, and hangs forever. When I reset and wake up
the board, I get a box: "Program received signal SIGTRAP"
and no printout.

3) Just for yucks, I tried clicking 'Run->Run' again,
and it downloads again, then hangs forever (no
initial breakpoint). When I try reset and
wakeup, I again get the SIGTRAP.

-----Original Message-----
From: Jonathan Larmour [ mailto:jlarmour@redhat.co.uk ]
Sent: Thursday, April 13, 2000 9:20 AM
To: Paul Kinzelman
Cc: 'ecos-discuss@sourceware.cygnus.com'
Subject: Re: [ECOS] building tests


Paul Kinzelman wrote:
> 
> Thanks very much Gary and Jonathan!
> Using 'continue' works with -nw!
> However, the View->Console sees only gdb output, not the
> program output. How do I view the program output (which
> I do get with the -nw version)?
> 
> I can run, for instance, 'stress_threads', under -nw, and
> I see a bunch of output from the program. But if I run it
> under the gui, I see only download messages and breakpoint
> messages.

Are you sure you had the console window up *before* you started running the
program?

Jifl
-- 
Red Hat, 35 Cambridge Place, Cambridge, UK. CB2 1NS  Tel: +44 (1223) 728762
"Plan to be spontaneous tomorrow."  ||  These opinions are all my own fault


More information about the Ecos-discuss mailing list