[ECOS] tcp_source/sink/echo small read/write size and "setsoftnet"

Grant Edwards grante@visi.com
Tue Apr 11 08:31:00 GMT 2000

My application that's running eCos (ARM7TDMI) and the TCP/IP
stack is seeing a panic from the stack after a minute or two
under certain conditions.  The panics we're running are

    m_copydata: null mbuf in skip
    m_copydata: null mbuf

This application does a lot of transfers of small amounts of
data (50-100 bytes) using TCP/IP.

In trying to duplicate the problem with some of the eCos test
programs, I tried to lower the buffersize in tcp_source.  It
seems to work fine down to about 100 bytes, but below that
starts to fail.  I've tried buffer sizes of 60-70 bytes and
after a second or two, the data trasfer just stops.  Sometimes
I get "setsoftnet" messages on the diagnostic port.

Q: Should buffer sizes of 60-70 bytes work in the tcp_echo
   test? I can't see anything in the source that leads me to
   believe short buffer sizes should fail.

Grant Edwards

More information about the Ecos-discuss mailing list